Hot answers tagged

7

I use JCE Editor on all our sites, but we have started also installing Sourcerer by NoNumbers. This gives an easy INSERT CODE button to the JCE editor that protects it from being modified. http://www.nonumber.nl/extensions/sourcerer


5

Maybe I misunderstand your question, but you say: I copy some youtube embed code > paste it into TinyMCE editor > it appears like this and I immediately click toggle editor > it appears like this; Please note that if you paste HTML code in the regular TinyMCE window, it will be converted to HTML entities (< becomes &lt;, > becomes &gt; ...


4

The solution is a bit tricky but it should work. Open this file [root]/media/editors/tinymce/tinymce.min.js (yes, it's minified), try to find this part function(){var n="Andale Mono=andale mono,times; change it to function(){var n="Your New font=your new font,sans-serif;Andale Mono=andale mono,times; then open file [root]/templates/...


4

In your admin side, go to "Extensions" -> "Plug-in Manager". Then click on "Editor - TinyMCE". Now enter the td[*] for "Extended Valid Elements" and save it.


3

I ran into the same issue with a couple of Joomla instances. Did you export the local database and import in on your remote server using phpMyAdmin? There's a bug in phpmyadminversion 4.6.5.1 that places /n/r incorrect in the data when doing an export/import. Try updating to phpMyAdmin to at least 4.6.5.2 where this issue was fixed. Answer thanks to Isaan ...


3

From how to add an iframe Log into your Joomla 3 administrative dashboard In the top menu, click Extensions and then click Plug-in Manager In the left menu under Filter, click Select Type and then click editors. In the list of results, click Editor - TinyMCE. At the top of the page, click the Basic Options tab Scroll down until you find ...


3

I have had similar issues in the past where scripts seem to be stripped regardless of the text filter settings. Temporarily Disable Editor As a temporary work around, you can temporarily set the Default Editor to "None" each time you edit the content. This works but is not convenient especially when you or another administrator forgets to disable the ...


3

I had a lot of trouble with this until I realised you have to select the correct TinyMCE panel set before editing the Prohibited elements. Choose the set that is assigned to administrator and editor. [


3

I'll make this an answer so I can explain a little better at ease. Ok so I'm not sure if this is a feature you want to make available to the public or if it's purely for your own benefit, but I would personally approach this a different way. The only efficient way to do this without editing a core Joomla file is to develop a plugin. So you have 2 choices ...


2

There are some secret settings for JCE. I know the following setting stops &nbsp; being added to empty divs, maybe used to clear floats, which causes line-height issues when rendered: In the Editor Global Configuration, add: remove_div_padding:1 to Custom Configuration Variables. I would expect there are more that can control any aspect of the editor....


2

You need to do the settings in either TinyMCE or JCE based upon which one you are using (set in Global Configuration or overrided in your user account). In JCE, the setting is in Editor Profiles->Default->Typography-> Container Element & Enter Key:


2

If you are wanting to add in the additional editor features like images and whatnot there is more to it that just added the js files. Personally I would recommend using Joomla's native method of displaying the editor, this is gonna give you the best results and all of the features you want. It should also work with whatever your default current editor is. ...


2

The current version of TinyMCE (v4.4.3) now seems to have this option enabled (see below).


2

I am a big fan of the NoNumbers Sourcerer plugin. It allows you to put any type of code into articles and custom modules very easily and the free version will do what you need. There have been several times that I had done troubleshooting to same issue as you, fixed it, and then some future upgrade broke it again and I lost my code. This way protects you ...


2

Here is my solution: At first: remove meta and link from the source code is not part of the joomla filter. it is part of the core. So modify the core is not a solution about problem with later updates. Second: the third part component sourcer can work but it is a third part solution out of my control for validation and verification. And every additional ...


2

What you've currently link to in your question is a plugin event for a custom editor button, not for the actual creation of one. To create a custom button, check the following directory: ROOT/plugins/editors-xtd/ where you will see a few core extension. You can copy any of these and start writing your code inside the onDisplay() function


2

(Replicated response from Stack Overflow per request) Rather than replacing the files (which could be overwritten in any future update), you're probably better off writing a new plugin for Joomla that installs Tiny 5. The source code for the (v4) TinyMCE plugin is a good place to start to write your own - replicate how this plugin works, and you'll need to ...


1

COMPONENT--> JCE EDITOR--> EDITOR PROFILES--> DEFAULT-->PLUGIN PARAMETER then mark "Allow IFrames"


1

You can edit a custom set in Plugins -> TinyMCE, cleaning out most of the buttons, and assign to the target user group. But that will make the same minimal set be used all over the site if the user is in the targeted user group. If you change your editor to JCE, you can assign a profile (set) to either/both frontend and backend, assign by device (desktop, ...


1

You can configure a customized editor in your component (we could write a long tale about that), however what I would do is just creating a simple textarea in your Joomla Form like: <field name="mytextarea1" type="textarea" default="default" class="mytextarea1" label="Enter some text" description="" rows="10" cols="5" /> Then you should add a short ...


1

'No color' is the correct option. You should add some custom css to your site to control the the colour of your text. Note: the 'no color' option does not mean transparent; it means no inline style will be applied to the html tag by the editor. If you cannot see the text, then you have a css problem, not a wysiwyg problem.


1

You have to write a TinyMCE Plugin: https://www.tinymce.com/docs/advanced/creating-a-plugin/ And use the TinyMCE-Api to inject your shortcut: https://www.tinymce.com/docs/api/tinymce/tinymce.shortcuts/ How to add your plugin to TinyMCE: Creating custom plugin for tinymce


1

There are several tags that are prohibited by the Joomla text filter. Go to Global Configuration Click the "Text Filters" tab. At the bottom of that page, you'll see a yellow section where it defines tags present in the default blacklist. Any usergroup that's been assigned the default blacklist will be restricted/prevented from using the tags in the ...


1

Try changing false to true in your last line: echo $editor->display( 'desc', '', '400', '400', '20', '20', true, null, null, null, $params ); Here's a quick screenshot from Joomla 2.5. Note that according to your screenshot, your default editor seems to be JCE, not TinyMCE.


1

TinyMCE removes empty tags by default, so a tag like <script src="myScript.js"></script would be removed because it's empty. You can try changing the settings of the TinyMCE plugin (Extensions -> Plugins -> **Editor - TinyMCE) and add the following text to the Extended Valid Elements field. script[*] That should allow you to add JavaScript ...


1

We were never able to solve this with Tiny MCE either. As Neil suggests, you merely turn it off entirely while using it, or utilize Sourcerer from the component formerly known as NoNumber. Alternative: Install JCE as your editor. There you have the ability to set it to allow script, iframes, etc, and you have a better editor with more control at the end of ...


1

You can consider change to JCE Editor. This component its great, free and have too many options to manipulate images. Included this your need for title Image. Try In: https://www.joomlacontenteditor.net


1

You also can add an image in the Image Button at the bottom, see the screenshot. From here you can add your image title. Best Regards!


1

Emoji's a 4 byte characters. This means that your database needs utf8mb4 support to deal with this. Joomla currently does not support this and this is the result (this was part of the cause of the security vulnerability in 3.4.6 and also a similar wordpress security issue from about 12 months ago). The fix has been included in the 3.5 branch for nearly 6 ...


1

Though I am not TinyMCE expert, looking into the unminified version of tinymce.min.js I would say all plugins are loaded automatically (with themes and languages) if they follow the convention of storing them under plugins directory: /plugins/{plugin_name}/plugin.min.js Here is the piece of code I think is responsible for loading: function t() { var e ...


Only top voted, non community-wiki answers of a minimum length are eligible