6

I'm getting 500 errors showing on my site after renaming htaccess.txt to .htaccess

  • This is generally expected, you need the .htaccess file enabled for most features of Joomla – tim.baker Dec 8 '14 at 18:57
  • 6
    How can 500 errors be expected? – johanpw Dec 8 '14 at 18:58
  • 1
    I'm not sure that it is generally expected and Joomla can function perfectly without .htaccess being enabled (or at least mod_rewrite enabled) – RustyJoomla Dec 8 '14 at 19:12
  • Just enable "Use URL Rewriting" in Global Configuration from the Admin panel. – user3927 Mar 20 '15 at 13:28
4

Just some additional information on this error, copied right out of the default htaccess.txt file that comes with Joomla:

# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

Another line that might cause errors is the RewriteBase (home page will work, all links will give a 404 Not found error):

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

This line is needed if your Joomla installation is located in a subfolder of your domain. Add the name of the subfolder after the / (e.g. RewriteBase /joomla). Note that this is not needed when Joomla inside a subfolder used as addon domain in cPanel.

1

To resolve the issue, on line 19 of the file, I replaced

Options +FollowSymLinks

with

#Options +FollowSymLinks
  • Not sure if this is further information, or the answer :) Can you accept the answer if it is, or move the changes you made to the question as further detail. :) – GDP Dec 8 '14 at 15:04
  • This has solved it, I've put it as an answer for anyone else. I can't accept the answer until 2 days time – RustyJoomla Dec 8 '14 at 15:07
  • Cool...it was asked and answered so quickly, I wasn't sure :) – GDP Dec 8 '14 at 15:09
0

In my setup, a wamp update had reset my Apache .conf file, and I found out that the module mod_rewrite was disabled!

So I just enabled it by un-commenting that specific line and It was working fine, after restarting the server, also read this answer.

-1

My website's problem is solved by changing 2 lines of .htaccess file:

  • Comment Options +FollowSymLinks as below:

    #Options +FollowSymLinks
    
  • Uncomment #RewriteEngine On as below:

    RewriteEngine On
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.