1

The problem starts with my attempt to use CDN77: After installing and setting cdn plugin, all my source files' URL turn to the cdn provider's URL. Everything is working except font awesome icons, which generates some cross domain problem. According to this page: https://client.cdn77.com/support/knowledgebase/cdn-resource/firefox-not-loading-cross-domain-name-fonts, and because my server is apache, I added following to the end of my htaccess.txt:

<FilesMatch "\.(ttf|otf|eot|woff|woff2)$">
  <IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin "*"
  </IfModule>
</FilesMatch>

But it doesnt work. I think it could be because mine is htaccess.txt file while the instruction is targeting .htaccess file.

In my htaccess.txt file I see only # signs and texts and no <> block at all, which also raises my doubt that the two files should have different syntax. I tried what this page says but if I change htaccess.txt to .htaccess, I will always get a 500 error. So I am stuck here, could anyone please help?

1

You have to rename htaccess.txt to .htaccess if you want the settings to take effect on your server.

From the Apache documentation:

.htaccess files (or "distributed configuration files") provide a way to make configuration changes on a per-directory basis. A file, containing one or more configuration directives, is placed in a particular document directory, and the directives apply to that directory, and all subdirectories thereof.

As you have noticed, even the smallest error in this file will cause a 500 error, but the one that comes with Joomla usually works without any problems when you rename it to .htaccess.

Make sure you haven't made any changes to the original file. You can get the original file from here: https://github.com/joomla/joomla-cms/blob/staging/htaccess.txt.

Notice the following lines and consider commenting them out (by adding a # at the beginning of each line) if you still get 500 errors:

## Can be commented out if causes errors, see notes above.
Options +FollowSymlinks
Options -Indexes

You should also pay attention to the following line:

# RewriteBase /

If you're having trouble with 404 errors (links not working), and you access Joomla using a subdirectory (e.g. http://example.com/Joomla), you have to change it to

RewriteBase /Joomla

Any line starting with the sign # are treated as comments and completely ignored by the system. You'll notice the file has a lot of useful comments.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.