1

Recently migrated a J3 site to J4.2.8

I had to uninstall a lot of plugins before the migration, and a few after, but everything appears to be working apart from one thing.

In the Joomla admin area, wherever I open a module and click 'save' or 'save and close', the following error message is displayed;

Call to undefined method Joomla\CMS\Application\AdministratorApplication::isSite()

I have set my error reporting to maximum, no additional errors.

I have also set logging to 'everything', when I check administrator/logs/everything.php I see the following;

#Software: Joomla! 4.2.8 Stable [ Uaminifu ] 16-February-2023 15:00 GMT

#Fields: datetime   priority clientip   category    message
2023-02-17T14:03:57+00:00   CRITICAL ::1    error   Uncaught Throwable of type Error thrown with message "Call to undefined method Joomla\CMS\Application\AdministratorApplication::isSite()". Stack trace: #0 [ROOT]\libraries\src\Plugin\CMSPlugin.php(279): plgSystemNRFramework->onExtensionAfterSave('com_modules.mod...', Object(Joomla\CMS\Table\Module), false)
#1 [ROOT]\libraries\vendor\joomla\event\src\Dispatcher.php(486): Joomla\CMS\Plugin\CMSPlugin->Joomla\CMS\Plugin\{closure}(Object(Joomla\Event\Event))
#2 [ROOT]\libraries\src\Application\EventAware.php(107): Joomla\Event\Dispatcher->dispatch('onExtensionAfte...', Object(Joomla\Event\Event))
#3 [ROOT]\administrator\components\com_modules\src\Model\ModuleModel.php(1029): Joomla\CMS\Application\WebApplication->triggerEvent('onExtensionAfte...', Array)
#4 [ROOT]\libraries\src\MVC\Controller\FormController.php(676): Joomla\Component\Modules\Administrator\Model\ModuleModel->save(Array)
#5 [ROOT]\administrator\components\com_modules\src\Controller\ModuleController.php(241): Joomla\CMS\MVC\Controller\FormController->save('id', 'id')
#6 [ROOT]\libraries\src\MVC\Controller\BaseController.php(672): Joomla\Component\Modules\Administrator\Controller\ModuleController->save()
#7 [ROOT]\libraries\src\Dispatcher\ComponentDispatcher.php(143): Joomla\CMS\MVC\Controller\BaseController->execute('apply')
#8 [ROOT]\libraries\src\Component\ComponentHelper.php(355): Joomla\CMS\Dispatcher\ComponentDispatcher->dispatch()
#9 [ROOT]\libraries\src\Application\AdministratorApplication.php(143): Joomla\CMS\Component\ComponentHelper::renderComponent('com_modules')
#10 [ROOT]\libraries\src\Application\AdministratorApplication.php(186): Joomla\CMS\Application\AdministratorApplication->dispatch()
#11 [ROOT]\libraries\src\Application\CMSApplication.php(294): Joomla\CMS\Application\AdministratorApplication->doExecute()
#12 [ROOT]\administrator\includes\app.php(61): Joomla\CMS\Application\CMSApplication->execute()
#13 [ROOT]\administrator\index.php(32): require_once('C:\\xampp\\htdocs...')
#14 {main}

This is the stack when I enable debug.

#   Function    Location
1   ()  JROOT\plugins\system\nrframework\nrframework.php:68
2   plgSystemNRFramework->onExtensionAfterSave()    JROOT\libraries\src\Plugin\CMSPlugin.php:279
3   Joomla\CMS\Plugin\CMSPlugin->Joomla\CMS\Plugin\{closure}()  JROOT\libraries\vendor\joomla\event\src\Dispatcher.php:486
4   Joomla\Event\Dispatcher->dispatch() JROOT\libraries\src\Application\EventAware.php:107
5   Joomla\CMS\Application\WebApplication->triggerEvent()   JROOT\administrator\components\com_modules\src\Model\ModuleModel.php:1029
6   Joomla\Component\Modules\Administrator\Model\ModuleModel->save()    JROOT\libraries\src\MVC\Controller\FormController.php:676
7   Joomla\CMS\MVC\Controller\FormController->save()    JROOT\administrator\components\com_modules\src\Controller\ModuleController.php:241
8   Joomla\Component\Modules\Administrator\Controller\ModuleController->save()  JROOT\libraries\src\MVC\Controller\BaseController.php:672
9   Joomla\CMS\MVC\Controller\BaseController->execute() JROOT\libraries\src\Dispatcher\ComponentDispatcher.php:143
10  Joomla\CMS\Dispatcher\ComponentDispatcher->dispatch()   JROOT\libraries\src\Component\ComponentHelper.php:355
11  Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT\libraries\src\Application\AdministratorApplication.php:143
12  Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT\libraries\src\Application\AdministratorApplication.php:186
13  Joomla\CMS\Application\AdministratorApplication->doExecute()    JROOT\libraries\src\Application\CMSApplication.php:294
14  Joomla\CMS\Application\CMSApplication->execute()    JROOT\administrator\includes\app.php:61
15  require_once()  JROOT\administrator\index.php:32

I have Advanced Mod Manager and Advanced Template Manager installed but they're both disabled.

Any ideas?

3

1 Answer 1

0

The NR Framework system plugin is from tassos.gr. Uninstall of the tassos.gr plugin did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.