GoDaddy is providing one-click installation for Joomla 2.5. If you want to implement Joomla 3.0 from scratch, FTP is the way. The reason for the same is unclear to me. I guess htaccess.txt is one place that creates confusion. Right now, getting "input file not specified" message when I click any menu on my website iwebazoid.in. It will be great if someone using Joomla 3.0 with GoDaddy (Linux) forwards their htaccess.txt file so that I could implement the same for my website.

Edit1: By renaming to .htaccess and uploading the same through FTP, I waited for 20 minutes without any change of status. Then, under Global Configuration, I turned off SEF and Use URL Rewriting which immediately addressed issue of "input file not specified" when I click menu buttons to open a web page inside the website. I have kept .htaccess file as it is that is shipped with Joomla 3.3. Now, my hurdle is I am still getting the site live when I type http//iwebazoid.in but not with www.iwebazoid.in (page ok message).

I have read that this is a problem specific to GoDaddy which will correct itself within 2 weeks at max. Should I wait or I need to do something from my side?

  • Sounds like you set "Use URL rewriting" to "Yes" and have forgotten to rename htaccess.txt to .htaccess as @ToniMarie mentioned. If it does not work, try this instruction.
    – Farahmand
    Commented Nov 15, 2014 at 17:32
  • I wish GoDaddy was bought out and put into liquidation. Absolutely despise them.
    – Lodder
    Commented Nov 15, 2014 at 18:58

2 Answers 2


From a quick google search I did, this seems to be a GoDaddy server issue.

Below you will find some troubleshooting steps, copied from a similar thread in joomla.org forum.

1) From the Joomla Control Panel go to "global setting" and under the Site Tab turn off SEF and Apache ("Use URL rewriting" for 1.7 users).

2) Now move your .htaccess file to your computer via FTP if you don't have this file move htaccess.txt to your pc and open the file.

3) Remove any #'s if any from RewriteEngine On and RewriteBase / Note: if your site is on a sub-directory the above should appear like this RewriteBase /yourJoomlaRootFolder/

4) Search for Options +FollowSymLinks and add the below right after it. Options -MultiViews

5) Save the file and move it back to your server. *If the file was originally named htaccess.txt rename it to .htaccess and then move it back to the server.

6) Turn on SEF and Apache ("Use URL rewriting" for 1.7 users)

7) Now Check to see if it is working. If it still isn't working or its happening less frequently move on to step 8.

In your Joomla root directory look for "php.ini" and rename it "php5.ini" (no quotes). If the file does not exist on your local computer open notepad if it does test again to see if it works. If it doesn't proceed to step 9.

9) Move the new php5.ini file to your computer (if it didn't exist keep notepad open)

10) Add this line, "cgi.fix_pathinfo = 1" (no quotes), to the document and save the file by going to File -> Save As -> under Save as type change it to All Files -> Change the file name to php5.ini if it isn't already named that. Note: You may also want to add the below to the document to change your max doc upload to joomla (you may edit it as needed).

cgi.fix_pathinfo = 1 memory_limit = 50M post_max_size = 10M file_uploads = On upload_max_filesize = 10M upload_tmp_dir = /home/content/55/6067155/html/tmp

11) Check your site thoroughly again before moving on to the last step which solved my problem.

12) Login to your Godaddy Account. Go to your hosting account. Go to Settings > File Extensions Management and edit .php and .php5 from "PHP5.2xFastCGI" to "PHP5.2X"

13) Test out your site if this still doesn't work Contact GoDaddy and make sure you send them all of the above information because you may have a server issue.

Also check this question: « Joomla “No input file specified” on GoDaddy server » in SO


I haven't used GoDaddy in a while but it used to be that it took 15 minutes for .htaccess changes to become active. And you do know that you have to rename htaccess.txt to .htaccess before the site can go live.

So after installation, renaming .htaccess and then waiting 15 minutes used to be the norm. I'm not sure if they've improved that situation at all.

  • I have renamed htaccess.txt to .htaccess but when I upload the file through cPanel (easier for me to work with cPanel instead of FTP), getting the name as .htaccess.txt file. Is it okay? Thanks! Commented Nov 16, 2014 at 3:46
  • .htaccess.txt will not work. You'll have to use real FTP so that the file is uploaded without a forced txt extension.
    – Toni Marie
    Commented Nov 16, 2014 at 4:02
  • Okay, I am working on it. Commented Nov 16, 2014 at 4:05
  • The issue is resolved but only at the cost of SEF off. Commented Dec 22, 2014 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.