0

I was having difficulty with a Joomla! site and decided to move it to another server for testing. The Akeeba backup I had would not fully extract for some reason (a large backup file included in the backup), so I downloaded all 30k+ files manually via FTP and uploaded them directly to the new server. I, also, backed up the database via phpMyAdmin and restored it to the new server.

When I access the front-end of the website, everything loads and works as it should. However, when I access the administrator, I receive the following message after logging in:

Failed to start the session because headers have already been sent by "/home/userfolder/public_html/plugins/system/statusindicator/statusindicator.php" at line 169.

I cannot access any administrator pages after logging in. I've tried installing the Joomla! core over the top and that did not fix it. I've, also, tried resetting the db credentials and that did not fix it.

What could be the issue causing this error?

  • BTW, I am testing this site on the new server by modifying my local hosts file. – Michael Yaeger Jun 27 '18 at 15:56
  • 1
    Hmm, this isn't a core Joomla plugin, so perhaps go to PhpMyAdmin, go to the #__extensions table and set enabled to 0 for plg_statusindicator. Then try accessing the page again. If it works, re-enabled it. – Lodder Jun 28 '18 at 16:10
  • Disabling it fixed the issue. However, as soon as I re-enable it the error comes back. I'm unsure why the plugin isn't causing the same error on the original server! – Michael Yaeger Jun 29 '18 at 12:39
  • BTW, this plugin is a part of the ActiveHelper chat server, so I can contact them directly from here. Post your comment as an answer and I'll mark it. Thanks! – Michael Yaeger Jun 29 '18 at 12:41
  • Asking Lodder to post his comment as a solution is not recommended because it is not actually a solution. If you eventally figure out how to ob_start() or similar output buffer technique to allow the header, then feel free to post an educational answer and mark that with the big green tick. However, I feel that the best solution is to manually shift the lines of code that precede session_start() to alleviate the issue... session_start() is always recommended to be the first line of code (following <?php) on any script that intends to use or maintain session data. – mickmackusa Jul 17 '18 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.