1

I'm facing an issue when I try to migrate a Joomla installation to a different server. Let me first of all say I have copied all files from the old server to the new one, and migrated the Joomla database to a different server.

I've updated configuration.php to reflect the changes in the MySQL server.

When loading the site, it apparently works fine: connects to DB and allows all operations. However, when trying to access to the Joomla administration panel, and after successful login, an empty screen appears. There is no possible way to enter the backend.

I've configured the configuration.php file to enable error reporting:

public $error_reporting = 'maximum';
public $debug = 1;

Also, I've introduced the next line in the administrator/index.php file:

error_reporting(E_ALL);

Despite of all this, no error appears in the Apache2 log (/var/log/apache2/error.log) nor in the Joomla logs (/var/www/logs/error.php).

I've tried disabling manually in the database some extensions, and actually came up with the fact that disabling the extension 'Jomsocial Update' allows to enter the backend, although the Jomsocial administration site cannot be accessed (a blank page appears once again).

For me, the weird thing is the fact of not getting any error at all in the logs.

Both the old and the new server have the same Apache version (2.2.22). However, the old server has PHP v5.4.6 whereas the new server has PHP v5.3.10. I've also tried installing PHP v5.4.28 from a non-official repository, but it also failed.

Do you know what may be happening? Thanks a lot for your support.

migrated from stackoverflow.com May 27 '14 at 15:14

This question came from our site for professional and enthusiast programmers.

  • Is it possible you have different PHP versions on the two servers? Also consider focusing on he plugins one at a time, most likely it is a jomsocial plugin, in which case I'd check their forums for help. – Elin May 23 '14 at 21:09
  • Yes, versions were different, and I tried with different versions as well, but the problem turned out to be related not with the PHP version, but with extensions. You can see my answer below. Thanks! – baldo May 24 '14 at 0:54
  • I've checked my curl is enabled and this problem still persists, yet if I delete the jomsocial user plugin then i can log in, but jomsocial does not work on the frontend either – user1710 Jul 30 '14 at 11:34
3

After working on this the whole day, I finally came up with the solution. It's just that php5-curl was not installed. As simple and stupid as it sounds.

So what was happening most likely is that Jomsocial / Jomsocial Update plugin required curl to display their administration sites. I guess Jomsocial Update was executed everytime the admin went into the administrator panel, and that's why disabling it prevented from blank screen of death (whereas the Jomsocial admin site was not accessible anyway).

Still, I'm confused about the way of coming up with the solution: this happened to me in other scenarios, but you usually find the solution because logs are quite explicit in printing out that curl_init() is not defined. How messed up can this be so that absolutely nothing was recorded in the logs?

Well, actually pretty messed up. While writing these words, I had a feeling of what could be happening. Yes, curl_init() calls are preceded by the '@' operator, which silences out errors even when E_ALL logging is defined. I don't know whether this is common coding style but for what it respects to debugging, it just turns it all into a hell.

Anyway, that's the answer for anyone who may have the same problem.

Regards!

  • Thanks for leaving your solution. Something similar happened to me as well without any error logs to rely on, and what I did was go into the database and disable the plugins manually to see if I saw any changes. – Prastow May 24 '14 at 12:44
  • Sure, I did that as well, but of course I had to disable plugins that I wanted to be active. I'll post in JomSocial forums soon to ask them to handle errors in a different way, or to remove '@' operator at least if Joomla debug mode is enabled. – baldo May 24 '14 at 13:31
  • 1
    @ operators are just wrong, i mean there are rare cases when there is no better solution but they are rare ... this is a great example of why. But you should accept your own answer. – Elin May 24 '14 at 13:50
  • Thanks Elin, as I said, I'll suggest in the Jomsocial Community to remove them at the very least if debugging is enabled. Also, PHP recognizes this problem with '@' operator in the documentation: php.net/manual/en/language.operators.errorcontrol.php I can't accept my own answer until tomorrow. Regards! – baldo May 24 '14 at 17:43
0

Am Anthony, I run this website which has JomSocial as a community component for my members. Sure enough, I am here to try to assist someone who might run into a problem as mine since mine is so unique I browsed all over internet and could not even see a reason why am seeing my screen of Death. I will say how I came into the problem.

  1. I am into the habit of doing a back up for my online websites, then reloading them in my local host just to be 100% sure I have a fully functional back up. I do this using the back up wizard at the Cpanel of my domain.
  2. So I did the back up, then once all files were offline (my Database and Public HTML archive), . =I extracted my archives, pasted the website in my local host, restored the Database and tried accessing the site. Sure enough I met a white Screen something I have never met.
  3. To cut story short, after about 2 hours of trying and failing, I checked all the folders that were extracted, to my disappointment my archive did not extract the folder "Components" so I copied it manually from the website that I had originally used to upload the one that is online, I had not installed an extra component since hosting the website so I was sure all components that I need are somehow present in that folder {But I was just guessing I was not sure if it will work or not}, pasted it in the folder containing the rest of my website in my local host, then from there I was able to log in to the back end of my Joomla website, Cleared Cache and cleared expired cache and sure enough, my website loaded exactly as it is online.
  4. So my simple advice, before you go about checking what is causing the WSOD moreso after migrating your website to another host, manually cross check to ensure all your files and folders are present, I just did that after getting a real challenge figuring out what is wrong with my website. I am surprised this advice did not pop up anywhere all over the places I searched online!
  • Thanks for posting how you solved your issue. However, the case of corrupted files after moving them around has been mentioned and discussed many times, more often in the form of comments though - but it's a common cause, when after a move the previously working site isn't working any more and usually, enabling error reporting will demonstrate this. – FFrewin Nov 20 '16 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy