I'm using Joomla 3.7.2.

I am not able to save any changes to my current modules or create new modules. I only make edits to my site in the administrator backend (siteurl.com/administrator).

Save and Save&Close both do not work with my site's modules anymore. Specifically, opening a module and clicking Save or Save&Close checks-in the module without making any edits. I also cannot make new modules or check-in modules from the list of modules.

What I can do

From the listing of all modules, I can open(edit), duplicate, publish, unpublish, and delete modules. If a module is checked-in, I can check it out by clicking on the lock.

However, I am not able to save any changes I make to modules.

This is quite strange because I am able to save changes to all other areas of my site (settings, users, menus, articles, categories, components). It is only modules that has an issue.


What I have tried (in no particular order)

I have tried restoring previous backups of my site (from when I was able to edit modules). Specifically, overwriting existing files and directories in my public_html root using Filezilla and then restoring the database backup in phpMyAdmin.

I have checked all global configuration settings, including settings for the Modules component. Administrators and Superusers are both allowed to configure ACL & options, Access Administration Interface, Create, Delete, Edit, and Edit State for Modules.

I have checked user group access levels. The account I am using belongs to the administrator and superuser groups. I have tried creating new administrator/superuser accounts.

I have tried clearing Joomla's cache and expired cache.

I have tried clearing my browser's cache (I am always in Incognito mode so I simply close my browser and start a new Incognito session).

I have tried both Chrome and Firefox (latest versions).

I have tried Fix on the Joomla database (Joomla backend->Extensions->Database->Fix).

I have downloaded the full stable release of Joomla 3.7.2 and overwritten Joomla's core files through Filezilla.


Recently, I have been having issues with two extensions (Joomfuse and Advanced Module Manager).

Joomfuse

I have tried disabling those extensions in combination with the above things I have tried.

I have tried uninstalling those extensions in combination with the above things I have tried.

I have tried reinstalling those extensions in combination with the above things I have tried.

Besides those changes, the only other change has been the installation (and removal) of Akeeba Backup.

I have contacted Joomfuse and Advanced Module Manager's support. While both teams are very helpful and responsive, so far, they have not had any success in helping resolve this issue.

If it makes any difference, our site


If anyone has any insights or possible suggestions as to what may be the issue, that would be much appreciated.

I am a recently graduated college student (undergraduate computer science minor) and feel very in over my head. None of my coursework covered websites. I have only had an introduction to data structures, software engineering, and program design. Over the past few months, I have learned about Joomla, Wordpress, and website administration through Google and trial-and-error.

Thanks in advance for any guidance that may be provided.

  • Did you manage to solve this? I have exactly the same problem on my live system but it works fine on my test system on my home computer. I think something must have changed on the host side but not sure what. – Ian Oct 3 '17 at 12:42
  • I have the same problem and took nearly the same ways trying to fix. Nothing helped. Does anybody solved the issue or find a workaround to fix it? – Michael Glorius Oct 18 '17 at 12:59
  • @MichaelGlorius I was not able to solve this issue. I created a clean Joomla install in a staging environment and copy-and-pasted all articles and modules. I did raise the PHP memory limit. – Michael Oct 19 '17 at 15:03

This is a good question as you have tried just about everything I can think of.

I only have a few suggestions.

Alternative Administrator Template

By default, the Isis template is enabled but Joomla also ships Hathor as an alternative administrator template.

You can change to Hathor by selecting "Administrator" in the drop down list at Extensions -> Templates and by clicking on the star in the Hathor row to set Hathor as the default.

Reinstall Core Files

Run a backup using Akeeba Backup or similar before trying this step.

At Components -> Joomla Update click the button, "Reinstall Joomla core files" to install any missing files and revert any custom coding back to the original core code.

JavaScript Console

Check for any meaningful error messages in the JavaScript console.

I had a similar problem to this (I wasn't able to save menu items) using the Isis admin template. The fix I found was to open the index.php in the Isis admin template and on lines 27 and 28 you'll find the following:

// Add JavaScript Frameworks
JHtml::_('bootstrap.framework');

on line 29, add the following

JHtml::_('behavior.framework', true);

So it should now look like:

// Add JavaScript Frameworks
JHtml::_('bootstrap.framework');
JHtml::_('behavior.framework', true);

The buttons then started working for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.