0

I had a Joomla 3 website installed on my Windows installation with WAMP. Then I uploaded it to a hosting service. After changing the config php accordingly, I can see the website up and running without an issue. When I go to /administrator and try to login, it directs me to a blank page.

Info :

  • PHP 5.4.45
  • Joomla 3.6.5

How can I fix this?

What I have tried so far

  • Cleared the session entries from the DB
  • Enable Joomla user plugin
  • Did a fresh installatoion to a temp folder, but that also do the same thing

Any ideas?

  • blank pages are usually caused by fatal errors. Enable error reporting and see if you get any – FFrewin Apr 8 '17 at 20:13
2

Some things to try:

  1. Check that the hosting environment meets the minimum requirements: https://docs.joomla.org/Technical_requirements

  2. Temporarily disable URL rewriting

  3. Temporarily disable the web.config file if you are hosting on Windows or temporarily disable the .htaccess file if you are hosting on Linux

  4. Set Error Reporting to Maximum to see if there is any meaningful error message

  5. Check PHP environment variables are set to reasonable values e.g. memory_limit = 256M

  • 1
    Sometimes, it is usefull to check the access and error logs of the web (apache2) server. – Tom Kuschel May 9 '17 at 4:28
0

I was also having this issue.. just changed the $secret value. Add any random numbers at the end of it's value.

It worked great!.

-1

Praneeth ! Try to open 'yoursite'/libraries/cms/html/behavior.php and find line 833: $document->addStyleDeclaration('html { display:none }');

perhaps it is not your friend in your case 1. just MAKE COMMENTS on this line /*... as php rules demand 2. save changes.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.