2

I got a Live-page (our school's homepage) which I backed up via Akeeba and already restored on my local server which I mage with XAMPP.

Now, when I want to surf my local page through localhost/schulpage/ then it always instantly redirects me to the live-version of my page www.example.com.

The only exception of this is when I surf the back-end localhost/schulpage/administrator.

But as soon as I click on login it redirects me to the backend of my livepage again.

How can I fix this? Already spent hours trying to figure it out but I don't have a clue where it comes from.

What have I already tried?

  • .htaccess files first renamed, then deleted -> nothing changed
  • config.php checked -> no live-page listed.
  • htacess.txt renamed, deleted -> nothing changed
  • Checked installed plugins, no obvious plugins installed.
  • 1
    Try clearing the Joomla cache if you haven't already. – Neil Robertson Feb 24 '17 at 0:06
  • If all else fails, search. Firstly, do a text search in the joomla folder for the domain name. configuration.php is the obvious place, but it could be in a template file or something like that. Then do a mysqldump of the database, then do a text search in the sql file for the domain name. It will show up somewhere. And when you know where it is, you can probably work out how to fix it from within Joomla. – Simba Feb 24 '17 at 15:54
2

There are several reasons Joomla redirect you to the live site.

  1. User plugin - Check if there is any user plugin which redirects user to live site. Try disabling the user plugin under Administrator->Extensions->plugins->select plugin type as user in dropdown
  2. Custom module - If you are using any third party then please check it's config setting for user login redirection
  3. htaccess - As per your question you already renamed it so it does not cause any trouble.
1

It could be set in redirect component or in some sort of system tools - like Admin tools. Check extensions installed on your school site.

0

We had this problem last week with a client. Remove the value of the $live_url from your configuration.php file. This should fix the problem.

So you should have something like:

public $live_site = '';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.