6

After upgrading my site to J3.5, users can't login anymore. They get the "invalid token" error.

I tried myself around 30 times and I also get the error, although I can login to the admin area.

I cleared Joomla cache, browser cache and truncated the #__session table.

But the problem persists.

This is critical! Users are paying to access certain areas of my site.

WHat more do I have to do to enable user login again????

  • One advice: Never, never upgrade (or even update) without making a copy of your website first! Plus it is highly recommended to test the upgrade on a copy of the website before doing it on the production website! – titchagcreation Mar 23 '16 at 9:10
  • @ Philippe: two years after your reply: thank! This finally worked for me after scanning many other discussions! Turning off the system cache didn't work. But adding the login-menu-item to the System Page Cache plugin helped. – user13227 Jan 10 at 7:34
5

Apparently there area couple of issues with Joomla 3.5.0, one being to do with the session.

Joomla 3.5.1 will be released tonight, hopefully fixing your issue.


It may be an idea to put your site offline for a couple of hours until the update is released. And in future, I'd recommend taking a backup of your site and testing Joomla updates locally before applying them to your live site

  • Ok, I always trusted Joomla team had done extensive testing before going live with a new version but at least it's good to know the issue has been addressed. Thank you – Nuno Nogueira Mar 22 '16 at 12:19
  • 2
    @NunoNogueira - Extensive testing is always done. 2 tests are required for small PR's (but usually more are done). Joomla 3.5 had 5 betas and 4 RC's. Some things can get missed though, just the way it is unfortunately ;) – Lodder Mar 22 '16 at 12:24
  • 1
    @Mikan - Cause I know people :) – Lodder Mar 22 '16 at 13:17
  • 1
    <envy>echo "cool"; </envy> – Mikan Mar 22 '16 at 13:33
  • 2
    twitter.com/GW1992/status/712274101293998082 lodder's contact just gave the game away on twitter i feel ;) – George Wilson Mar 22 '16 at 13:46
2

Turn off the System - Page Cache The issue is related to the cache.

  • Yes, that seems to fix the problem. But the cache is necessary so I still need a permanent solution. – Nuno Nogueira Mar 25 '16 at 19:47
  • 2
    I found that as soon as I login, "page" is in the cache. I clean the cache I can login back. It has to do with that but I haven't had time to dig deeper to see what's wrong. For now, no cache does it... waiting for a permanent solution too... – Ovi Mar 26 '16 at 15:37
0

The problem is caused by the cookie domain and cookie path, erase the content so that it looks like this:

public $cookie_domain = '';
public $cookie_path = '';

0

What worked for me:

  1. Install PCE - Page Cache Extended Plugin from this page
  2. Disable core Joomla cache and replace it by this plugin instead
  3. In the plugin configs, exclude components: com_users
  4. Use core Joomla component to register/login users. No mod_login no 3rd party extensions

PS: Joomla should allow disabling cache to whatever components/modules necessary. I can see it is already possible to exclude URLs but what if you have a module mod_login in main the main menu or a custom extension?

0

I had the exact same problem and I solved it in 2 simple steps:

  1. In Joomla! go to plugins / System - Page Cache

  2. In the plugin there is an option to exclude menu items. I excluded the menu item where the login form was located.

That's it. Now it works on my site. I can login, logout repeatedly and never get the invalid token error. NOTE: On logout, my users are redirected to the same page where they logged in (the one I excluded from system - page cache). I don't know if it plays a role or not.

Hope it helps.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.