2

Joomla 3.4.1

I was hoping somebody could briefly explain this for me. I am not that familiar with tokens, sessions or cache.

My site was working fine with no issues however I decided to enable the "System-Cache" plug-in and set "Use Browser Caching" to Yes. Since doing this I have been unable to login to the website, each time I receive a blank page with an error Invalid token.

I have since disabled this plugin, cleared cache and all is working well again, no login issues. So am I not able to use browser caching? Perhaps I should be doing something else? I couldn't find any definitive answers to this question, lots of people suggesting different solutions.

Tested with Chrome and IE if that matters.

Any advice appreciated.

2

There have been a lot of known (yet unfixed) issues with the System Cache plugin and Use Browser Caching when trying to login. A lot of people have reported an Invalid Token.

There are some other things that could be causing this. So try the following (some may not apply to your specifically)

  • Disable apache's mod_cache
  • Disable the server Memcache feature
  • Set Use Browser Caching to Off
  • Clear all cache and cookies from your browser

If you require caching, I'd recommend going with a dedicated caching extension. Perhaps JotCache.

Hope this helps

  • thanks @Lodder his info is really helpful! Hopefully Joomla will improve on the whole cache thing as there does seem to be a lot of frustration surrounding it. – jonboy Jul 10 '15 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.