1

My cache handler in Joomla! only shows 'memcached (experimental)', and not File etc. I was able to change the cache handler in my configuration.php but I'd still like to know why File is not shown as a cache handler option? How can I fix it? I checked folder rights already.

Thank you

  • Is this occurring on a server you manage/control or a hosted solution? – Brian Bolli Sep 11 '14 at 20:48
  • @BrianBolli It's a hosted solution but I installed Joomla myself. The update from 3.3.1 to 3.3.3 gave some problems as well to install but eventually worked. Could it be a problem on the host? – Bastiaan Sep 12 '14 at 14:06
  • 1
    Those options for caching are determined by what's available on the server's installation of PHP. However, in my experience this only applies for the various caching PHP extensions available, I've never seen where the default file option was not available. Can you FTP into your website root directory? If so, compare the configuration.php file on the server with the one included in a new full Joomla 3.3.3 installation archive. Since you mentioned the upgrade didn't go smoothly i wonder if the new configuration.php file didn't get updated. Compare the values and update with me one if not. – Brian Bolli Sep 12 '14 at 15:53
  • I have the same issue, on the same server but moved from a subdomain. I'm really confused I've never had this before. – Eoin Jun 25 '17 at 13:50
3

[1]: https://i.stack.imgur.com/FmHB9.png

First of all you should check the administrator/cache and /cache folders exist. Obviously file cache can't work without those folders. If they don't exist just create them and that may solve the problem. If the problem is still not solved then perhaps the below has happened.

This occurred to me when I transferred my site to a new location. When I investigated the configuration.php file at the bottom of the file

public $cache_path = '/home/xxxxxx/cache';

Was incorrect and had the old location. This was causing Joomla! to say:

Failed to load 'XXXXX' template: Joomla cache path does not exist! and in the back end cache path does not exist. I also could not see the file option in the global configuration. I also could not save the global configuration.

Editing my configuration.php file manually resolved this issue for me. enter image description here

And now you can also see the path to cache folder and edit it (bit late of course). I've submitted an issue to Joomla! as I think these fields should not disappear.

1

Create a folder called "Cache" to the root of your website (or to the directory where you have installed Joomla) and apply 755 permission to it. Then disable cache plugin, and you should be able to select "File" as Cache handler.

Hope it helps

PS: To remove "memcached" you can delete all the lines including "memcached" from your configuration.php file (remember to set 644 and when you finish editing back to 444)

  • This wasn't here, but adding it didn't help me. Any other suggestions? – Eoin Jun 25 '17 at 13:49
  • For the record I wouldn't advise deleting anything out of the Joomla! configuration file. That could easily lead to another question being posted later down the line. – Eoin Jun 25 '17 at 19:45
  • You could also try ensuring there is a cache folder in the administrator folder, but I believe my answer below solves it. – Eoin Jun 25 '17 at 19:46
0

Check that /administrator/cache and /cache folders exist and that your web servers has write permisions for it. You can check this in System->System Information->Folder Permissions tab - everything here should be green.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.