1

Since upgrading to J! 3.9.0 I'm getting this error on EVERY extension update except for the few who use an update routine that appears to bypass normal Joomla workings - StackIdea's EasyBlog and JoomlaShine's Uniform are 2 that will still update OK.

However, everything else (ALL of which have happily updated from the Update area in the past) fails. The extensions are all 3 types (component, module, and plugin) and are both paid and free. They all require manual installation to update.

I checked my /tmp path and it's correct and writable. configuration.php is, as I would expect, unwritable, but I saw in a different post some else's Folder Permissions screenshot showing it as writable so I changed it to 777. Still fail to install anything.

As I manage some 80 odd sites, this is a major time waster. Is anyone else experiencing this?

1

OK, found the issue and solution, but not the cause!

I went to the thread On RegularLabs' site - https://www.regularlabs.com/forum/exten ... ions#83452. In this, Peter talks about "some" server setting (he doesn't know which - or didn't at the time of writing) changing the case of the Header names. Because Joomla is looking case-sensitive, the installs failed.

He posted a patch for libraries/src/Installer/InstallerHelper/php which I copied and saved, then uploaded to 2 of my sites. Previously failing updates now performed perfectly.

|improve this answer|||||
  • I've just installed v3.9.1, which should include this patch, but I still get this error. Any advice? – Puce Dec 30 '18 at 23:00
  • @Puce if you are experiencing a similar issue, but this solution doesn't work for you, please post a new question with as much detail as you can so that volunteers can possibly lend you a hand. – mickmackusa Jan 30 '19 at 7:15
1
  1. Check if the system has free space.
  2. Check in System / Global Configuration / Server Tab / Path to Temp Folder if you have a full path (not relative one) to the tmp folder of your website.
  3. Check in System / Global Configuration / System Tab / Path to LogFolder if you have a full path (not relative one) to the logs folder of your website.
  4. Check in System / System Information / Folder Permissions tab if all the item are writable
|improve this answer|||||
  • Welcome to JSE. I see that you are no stranger to StackExchange, but please take our tour to see what slightly differs here. Thank you for joining us and contributing. – mickmackusa Mar 12 at 23:19
  • Can you tell me what I did wrong with my answer?. I had a similar problem like the question said and I posted my solution. nothing more. – NetVicious Mar 13 at 8:14
  • You did nothing wrong that I see. I welcomed you and upvoted your post. – mickmackusa Mar 13 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.