5

I have a J2.5 install that simply refuses to install a component using the extensions manager.

The directories are all writable, the Forum Post Assistant reports that session is writable, tmp path is ok, and the relevant directories have been made 777, and all files on the server have the same owner. Yet I still receive the following error when I try to install

JFTP: :mkdir: Bad response JFTP: :chmod: Bad response Component Install: Failed to create site directory: path.to/components/com_neorecruit

If I manually create the com_neorecruit directory then I receive the following error.

JFolder: :files: Path is not a folder. Path: path.to/administrator/components/com_neorecruit JFolder: :files: Path is not a folder. Path: path.to/administrator/components/com_neorecruit JInstaller: :Install: Cannot find XML setup file JInstaller: :Install: Cannot find XML setup file JFTP: :mkdir: Bad response JFTP: :chmod: Bad response Component Update: Failed to create admin directory:path.to/administrator/components/com_neorecruit

6

Maybe try disabling FTP at Global Configuration -> Server.

You may have a file ownership issue rather than a file permission issue. Changing to appropriate PHP file handler can sometimes help.

There is a more complete answer at: Recommended practices regarding Joomla file/directory permissions and ownership on linux systems?

4

It seems like Joomla cannot perform read/write operations via PHP, so I agree with Neil, it's likely to be a php handler / ownership issue (even though it was set at 777).

There is a troubleshooting list addressing your first error at http://docs.joomla.org/Why_can%27t_you_install_any_extensions%3F but it looks like you have checked off most of it :) I will list some of the points you may not have addressed below.

  • Check your php.ini file (it's usually located under /etc directory.) Make a backup, then if you can edit the original, set open_basedir to include the temp directory: open_basedir = /tmp If you have another path for tmp you can set it by adding :/path An example: open_basedir = /var/www/html:/tmp
  • Make sure you aren't using PHP 5.0.4. Apparently this version will cause the first error message you received.

Other things on the list (which you have already done) include

  • check that you have the correct tmp path in configuration.php
  • check that your session.save_path directive in your php.ini file is writable. I know you have done this already, but for other people with the same problem a lot of the above things can be checked using the Joomla Forum Post Assistant. It can be download from https://github.com/ForumPostAssistant/FPA/zipball/en-GB

If you use Admin Tools, it might be worth checking your .htaccess file. Admin Tools sometimes prevents access to some directories via the .htaccess file.

For your second error, I suggest you take a look at http://www.inmotionhosting.com/support/edu/joomla-3/server-settings/change-path-to-temp-folder They ran some tests using Joomla 3 and found that when they

removed all permissions from the temp folder and tried to upload a Joomla module in a .zip format, Joomla 3.0 gave us the following errors:

JFolder: :files: Path is not a folder. Path: /home/bradm/public_html/github2/tmp/install_503f7ef32c55c

This suggests to me it is the php handler/ownership issue as Neil suggested.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.