2

I keep getting errors when trying to upload to my tmp directory, it always fails if I try by URL or upload. The only way it works is via a direct upload Joomla extension.

As I have root access I have made sure permissions and ownership are correct and that the file path to my tmp folder is correct in global of admin as well as configuration.php so I am trying to figure out why it keeps failing.

I have chown apache:root on all my Joomla folders with permissions 755 and the path is mysite.com/joomla as it is in a sub-directory but all else works except for this. Also I noticed each time I do an install it fails to create the configuration.php file. Have I got ownership and permissions correct?

Update

The error was a number of things coming up but the main thing persisting that I remember and that is still there is tmp file folder not writable. I ended up clearing the cache via command and since then everything works but this one error message on tmp folder remains in warnings.

Further to this I reinstalled latest 3.6 with exact same ownership and permissions but used wget command for tar file and now it is all working no errors.

  • Can you clarify what you mean by "by url or upload"? – Craig Nov 13 '14 at 0:34
  • when you choose option to upload via a url address or via a folder locally. – cea Nov 16 '14 at 8:14
1

Open your apache configuration file and add these lines of code:

User apache
Group root

The file may be located in /etc/apache2 directory for example /etc/apache2/httpd.conf

As an alternative you may consider changing the ownership of files/folders to www-data:www-data recursively because this is the default user/group of apache:

chown -R www-data:www-data YOUR_JOOMLA_BASE_DIR
  • used to working with drupal and always set folders apache:root and 755 which always worked...is joomla different ? – cea Nov 12 '14 at 8:50
  • none of the above works but thanks. – cea Nov 12 '14 at 9:02
  • It's weird. These solutions have worked for all of my local projects. BTW I forgot to mention that when you use the first method, you must restart the apache server (sudo /etc/init.d/apache2 restart) or for the second method you must be a super user (type sudo before chown). Maybe this solve the issue. – Farahmand Nov 12 '14 at 12:13
  • yes i did all that but on mine its service httpd restart - so i am just using the joomla ext to upload and having to avoid any upload from url or local files. – cea Nov 12 '14 at 23:40
  • plus on centos it is actually apache:root that needs to be ownership and you never declare this in /etc/httpd/conf.d/conf file – cea Nov 12 '14 at 23:41
0
sync; echo 3 > /proc/sys/vm/drop_caches 

is the command used in centos to completely clear caches and after that still got the error but at least everything is working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.