I recently updated my Joomla site to 3.7.3 and it broke the site by displaying a blank page. I turned error reporting on and it gives me an error related to AbstractApplication.php.

The site: http://www.shelbypublicschools.org

Does anyone have any information for me on how I can fix this? I've updated my template to the latest version.

Thank you.

  • I tried to visit your site but sucuri says that my country is blocked.
    – FFrewin
    Commented Jul 17, 2017 at 17:20

2 Answers 2


I tried to visit your site but sucuri says that my country is blocked, so I can't see more about the error.

You can try re-installing Joomla from the admin (Joomla Update component) - or try a manual core re-installation as described here: Class 'JInput' not found after updating to 3.7.3.

You also need to make sure all your installed extensions are up-to-date and compatible with Joomla 3.7.3.

If you suspect that your issue comes from incompatible extensions, and that those extensions do not allow you to access the backend, can try disabling them - either through the database or by renaming their files/folders. Just note that in such case, it's better to know or document what you are doing, so you can revert back if needed.

Remember that it's always a good practice that apart of backups prior of updating, any software updates is better to be tested on a testing/dev site first and not directly on the production one.


I turned on maximum error reporting and chased the problem down to "Modules Anywhere" component. The upgrade destroyed that component. I couldn't wait for days on the component's message board for an answer, so I restored a backup from 2 weeks ago, then updated the Modules Anywhere component, then updated Joomla.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.