I'm having an issue while updating Joomla 3.6.5 to 3.7.0. Always when I try to update I get a Error message saying:

JFTP: :append: Bad response

So far I've tried:

  • Checked FTP settings in Configuration
  • Tried CHMOD 777
  • Played around with cache a bit in Configuration
  • Tried different types of the upload (Direct, Hybrid, FTP only)

Recently (about a month ago) I've updated the site to 3.6.5 with no hassle and problems. Configuration has never really changed after that, however we did have problems with the server (Service Provider) - last week "the PHP tried to run through FastCGI" (have no idea what it means, that's the exact quote from the server administrator who also said they solved it with restarting the server).

Any ideas?

Thanks! Jan

1 Answer 1


You can make direct update with update pack download from https://downloads.joomla.org/cms/joomla3/3-7-0, then install it via Extension > Manage > Install.

You also see more information about how to update Joomla! 3.7.

  • This doesn't answer why they are getting JFTP: :append: Bad response
    – TryHarder
    May 8, 2017 at 1:01
  • You disable FTP access via your global configuration, then process update Joomla!. After finish, you can make FTP enable again. May 9, 2017 at 1:23

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .