3

I recently updated Joomla and found that the database needed updating:

Database problem needs fixing...

When I tried to run the "Fix" by clicking on the button the frontend would then break with the following error:

Parse error: syntax error '/' in /home/<site>/public_html/plugins/system/nnframework/helpers/assignments/php.php(85) : runtime-created function on line 1
Fatal error: Function name must be a string in /home/<site>/public_html/plugins/system/nnframework/helpers/assignments/php.php on line 89

Another issue is that the template.css and template.js files in the backend seem to load incorrectly too - resulting in the page looking like a wall of text, links, buttons.

Does anyone know what would cause this? Or how I can trace a way to fix this?

  • 2
    Try updating all RegularLabs (nonumber) extensions to their latest version, then try again. – Lodder Aug 2 '16 at 13:29
  • Thanks, that - along with disabling/removing the old NoNumber Framework did the trick. – hazrpg Aug 3 '16 at 1:26
3

Update third party extensions to the latest versions if you're not already running the latest versions.

Once you are running the latest versions of the Regular Labs (formerly called "NoNumber") extensions, you can probably disable or remove the NoNumber Framework which may help.

A scrambled back-end layout can sometimes be fixed by clearing the Joomla cache and your web browser cache.

  • 1
    No I'm not, however I will try updating and see if I can disable/remove the NoNumber Framework. I'll report back once I have tried it. – hazrpg Aug 2 '16 at 13:33
  • 2
    That did the trick! Thank you very much for that piece of advice. I disabled the NoNumber Framework after updating the components - which then allowed me to update the db, then installed the other components I needed. However for the admin layout, I had to change the lines that had $document->addStyleSheetVersion() to $document->addStyleSheet() [i.e. take out the version part] reload the page, and then added the "Version" part back in. For some reason clearing the cache didn't quite cut it - that's not to say you weren't wrong, it just didn't work for me. I appreciate your help. – hazrpg Aug 3 '16 at 1:31
  • 2
    As a side note for anyone who comes across this - simply disabling the NNFramework didn't quite work 100% - I found removing it (or adding in "return true" to the top of the function being called if you want to see if removing will actually fix it) was the best course of action. – hazrpg Aug 3 '16 at 1:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.