I'd like to construct a script that imports an XLIFF file and updates the INI language files of our component. However, it seems that the language won't be updated unless the component is fully reinstalled. Why? Any way to hack around this?

Edit: I was editing the language file in the component folder. That one is not used. Those files are copied to root language/ and administrator/language/ folders during installation.

  • Are you talking about the admin lanaguages file or the front end? Can you expand your answer to show the languages bit of your manifest file. Are you using Joomla 3.7?
    – RichardB
    May 16 '17 at 10:14

The language files are loaded again (from their source) on each page load. You don't need to reinstall the component each time. Are you writing to the right file?

  • I was editing an admin INI-file directly on the server. I will test again. May 16 '17 at 11:03
  • Sorry, I cannot reproduce this behaviour. I edit the INI-file, reload, but string stays the same. May 16 '17 at 12:04
  • Seems like all component language files are copied to JPATH_ROOT/language/ and JPATH_ROOT/administration/language/. So when changing the component translations, I will need to run parts of the installation script in Joomla somehow, or just bluntly copy the INI files to both the component and the Joomla root language folder. May 16 '17 at 12:43
  • IMHO, this answer is only true, if the caching is disabled or you're logged-in. May 18 '17 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.