0

My site is running on Joomla3.

When I load my page for first time everything is fine (the default language is Spanish) -- even if I navigate in menus.

However, when I click the English flag and I navigate with the menus then I return to the Spanish language, it doesn't load anything -- everything looks white, the URL looks like this https://mywebsite.com, the www. is removed and it also contains the /es something like this https://mywebsite/es.

I don't know what to do. I know it's not the update because I when I test locally, everything works fine.

0

Turn off caching in global config. It seems to be not updating your files.

I have checked this on my own site and I ended up with /en/ behind the domain name and it was persistent. Then I held ctrl+shift+alt and clicked refresh.

Also turn off all language modules and plugins.

1
  • Hi, I don't have the caching on – Mara May 3 '17 at 16:55
0

Do you see an error message if you activate error reporting?

Maybe you can also check again that you have set everything up correctly: https://docs.joomla.org/J3.x:Setup_a_Multilingual_Site

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.