3

I have multilingual (fa/en) Joomla 3.6.2 site using Protostar template. The problem is when I click on the fa - (persian flag) or UK flag, the lang and dir tag does not change, but when I hit the refresh button they change to correct value. Also the site does not load correct CSS.

  • 1
    Do you enable the joomla cache or having any cache extension installed? – webchun Nov 14 '16 at 2:12
  • no i make this web from scratch with plain joomla 3.6.4 and the cache is disabled! – David Bereihi Nov 14 '16 at 12:58
  • 1
    Can you share the website url? – webchun Nov 14 '16 at 13:03
  • no,unfortunately .i'm working on localhost – David Bereihi Nov 16 '16 at 7:32
  • I am experiencing the same problem with Joomla 3.6.5. The problem may have been already there with 3.6.4. I disabled the cache in the system configuration and I disabled the cache plugin. So far I cannot observe a change: After about 2 page reloads, the website switches from German (set as default) to English. – Icarus Feb 12 '17 at 8:43
0

i rolled back joomla version from 3.6.3 to 3.3.3 and the problem solved !

  • 2
    hi - keep in mind that this can be considered as a viable solution though - as using older Joomla versions, especially outdated and vulnerable ones is not a good idea. So although it gave you a quick solution, this must be a temporary one and for your localhost site only to give you time to update properly the site. – FFrewin Dec 8 '16 at 10:16
  • thank u FFrewin do you have any Idea? – David Bereihi Dec 12 '16 at 21:42
  • You have to re-try to update (on a test site) to achieve a workable 3.6.4 site and try to find out what is the cause of your issues - if those persist. – FFrewin Dec 13 '16 at 7:45

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.