3

I've just migrated to Joomla 3 and my K2 URLs are returning 404's.

Before the migration this was an example of a correct URL: [url=https://www.portal-gestao.com/item/7687-o-que-significa-mass-customization.html]URL[/url]

After the migration, this page opens with this URL: [url=https://www.portal-gestao.com/slideshow/item/7687-o-que-significa-mass-customization.html]URL[/url]

So, the category is now behind the /item/ part of the URL.

It is very important, for SEF reasons, to preserve the old URL structure. I had the following line in .htaccess to force all K2 items to that structure:

RewriteRule ^.+/item/(.+)$ /item/$1 [R=301,L]

How can I bring this URL structure back?

Help please!

  • You can try to go to Menu Manager and and click Rebuild button to see if it helps. – Hung Tran Jun 16 '15 at 9:37
  • So, you need all of your K2 pages to load with just item/alias instead of using the category/item/alias? Did you, also, upgrade K2? Since you mention SEF, the new version of K2 has many more SEF settings that allow you to get rid of the "item" non-sense. – Michael Yaeger Aug 16 '16 at 1:53
  • Is this still an issue for you? – Michael Yaeger Sep 7 '16 at 1:06
1

When in K2 (in the Joomla admin), click on Parameters on the top right, and then click on the Advanced tab. Under Advanced SEF Settings, choose "Yes" next to Enable advanced SEF for K2 URLs and then choose "None" next to Prefix for item URLs. For good measures, choose "No" next to Use the category ID in the URL and choose "No" next to Use the category title alias.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.