0

Im trying to update to joomla! 3 from 2.5 but the update procedure do not work at all. this was the same problem i had when was trying to upgrade from 2.5.16 to 2.5.28) so its not a Joomla! 3 error. Basically it finds the update i press the button to install it and then remains forever in the next screen saying "Updating your Joomla! files. Please wait ..."

enter image description here

To update to 2.5.28 i copied the update with FTP hoping that a damaged file was causing the problem. When i log in with FTP i can see that update package its downloaded in the tmp directory. I am able to install and uninstall extensions.

thank you Mike

  • Have you any errors in the error.log file? – Dmitry Rekun Mar 17 '15 at 7:22
  • No there is nothing in error.log file. By the way i see in the tmp folder that it downloaded the update zip file but i never see any folder to be created for extracting. i dont know if it helps.. – Mike Mar 17 '15 at 7:45
  • Did you check file permission for your setup? – SD. Mar 17 '15 at 8:44
  • i used the akeeba admin tools to reset all the file permissions to the default ones. but if you have anything particular in mind i can recheck everything – Mike Mar 17 '15 at 10:07
1

I have the same trouble with an local installation. If you are using Xampp on a Win OS that might be the problem. It might also causes errors by using an Akeeba JPA File. Check this out: https://www.akeebabackup.com/products/cmsupdate.html

After installing try to run the update with this the software. For me it was an effective solution.

  • Hello Oliver. I have instaled the suggested and it gives me this error "There was an error communicating with the Joomla! package extraction script administrator/components/com_cmsupdate/restore.php. This usually indicates a permissions issue making this file unreadable to the web server or a server configuration (e.g. .htaccess file directives) issue blocking access to this file. Please consult with your host for a solution." (at list now we have an error! – Mike Mar 18 '15 at 18:27
  • You mentioned Admin Tools, did you use the .htaccess maker? It has a setting that blocks execution of PHP files other than the site and administrator index.php and exceptions you specifically list. I think that by default the Joomla (and cms update) restore scripts should be excepted, but if you used an old version of admin tools to make the .htaccess, the exceptions might be wrong. If this is the case adding th cms update restore script to exceptions and recreating .htaccess should help. – Ville Niemi Mar 18 '15 at 22:48
  • @Mike Forgot to tag my comment above, not sure if you get notified without? – Ville Niemi Mar 19 '15 at 7:03
  • hello @Ville Niemi, i reinstalled Admin tools but i dont see the .htaccess maker. maybe they removed it? Just to be sure i deleted the .htaccess file (i have a backup of course!) and try to update again but i receive the same error. – Mike Mar 19 '15 at 7:40
  • @Mike It is a feature in the Pro version, if you do not have it, it can't be the reason. Can you see with FTP or something what the rights and owner on the restore.php file are? – Ville Niemi Mar 19 '15 at 8:22
0

There is also a Joomla Installation Bug in some cases. Try this before running the update. Replace the file: yourinstallationfolder\installation\sql\mysql\joomla.sql with this file and try the update again. https://www.dropbox.com/s/4pibwrsmekem9r1/joomla.sql?dl=0

-4

Check the folders and files permissions. Тhey should be 711 for folders and 644 for files.

  • 2
    You mean 755, right? – Rene Korss Mar 10 '16 at 18:28
  • No! I meant 711 for folders inside public_html. – Stefan Bobevski Mar 10 '16 at 18:37
  • 1
    Why 711? Group and others couldn't read it. – Rene Korss Mar 10 '16 at 18:48
  • 2
    Steffan, they should be 755, not 711 – Lodder Mar 10 '16 at 19:14
  • Lodder and Rene, only user should be able to read files from his web folder if it is on a shared hosting server and the web server should be running under the same user when it comes to processes connected to him. Correct me if I am wrong for some reason – Stefan Bobevski Mar 10 '16 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.