In my domain, SSL is integrated via LetsEncrypt certificate and activated for the whole site in .htaccess.

An external page is linked in Menu with IFrame Wrapper.

This page is not displayed, even if I turn off SSL on the link in the meta tags.

Does anyone have an idea?

  • do you have a the link of the page? Commented Mar 18, 2016 at 19:12
  • sorry, no as a transitional solution I copied the source code in an Article
    – Jürgen
    Commented Mar 20, 2016 at 17:38

2 Answers 2


Check your browser console (press F12 to show) and see if there are any errors. It's likely that the website you want to show in your IFrame don't allow external sites to load the content. An example of this is Google, and trying to load google.com inside an IFrame gives the following error message:

Refused to display 'https://www.google.com' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

You can find some more information here: https://developer.mozilla.org/en-US/docs/Web/HTTP/X-Frame-Options and here: https://stackoverflow.com/questions/6666423/overcoming-display-forbidden-by-x-frame-options

Basically, if you can edit the page you're trying to display in the IFrame, you can solve it by changing the server settings. If not, you should respect the page owners request and don't include the page in a IFrame.


I run into the same problem after having installed server certificates over LetsEncrypt: IframeWrapper links ended in an empty page.

I tried the IframeWrapper option Metadata / Secure from IGNORE to ON or OFF - nothing changed.

Looking at the source code of the Iframe with firefox developer tools, I noticed, that the Iframe link after each change of the avove options started with http. After manually changing it in the source code tho https, the Iframe content suddenly appeared.

This helped me to find the very simple solution of the problem:

In Joomla Backend go to the properties of each IframeWrapper menu link and check the option

Advanced / Auto Add

from YES to NO

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.