0

Thanks to be in this great community. I need a little help :-(

I have Smart Search enabled in a perfect configured multilanguage site. All of content are indexed like i see in the backend, all languages are recognized. (So i don't have problem like older J3.x where not all contents are indexed if in a multilanguage status)

Default lang is EN, then i have IT FR RU ES and obvious the "ALL" language. When i search in smart search (finder) module, it does a search only for the content with the actual language.

I have content in EN IT FR RU ES and "ALL" languages.

It seem not possible to let Smart Search module find terms "transversally" in all languages enabled in site.

Is it a bug, a limit of Finder, or have i set something wrong?

Thanks!

  • There were some changes made to the languages in Joomla 3.4 which I believe still need fixing. Can't remember what they were exactly but might have something to do with it – Lodder Mar 5 '15 at 9:54
1

I was having the same problem today. On my categories I had a "master" category for each language as suggested on a multi-language website. The normal search and smart search both seem not to search on the ALL language articles. The way I fix it, was creating a third "master" category (with ALL language) where I included all the sub-categories which had ALL as the language. After the "master" categories, sub-categories and articles where all set to ALL as the language, the search started working as it should be. I don't know if this is a joomla bug, or this was intended, but it works.

Hope it helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.