3

We started getting a 404 error on a new site using Joomla 3.5. It is not open to the public yet. When testing it we just found that when we do open the site to the public it gives us a 404 error. When we are logged in and go to home page it works fine. As soon as we log out and go back to home page it gives the 404 error.

We have cleared the cache and checked the menus, etc. All are working fine until we open the site to the public.

I could use some help please.

  • Does the URL remain on the home page for the 404 or is it redirected? If you go to example.com, does the 404 show up directly there or on a redirected page like example.com/404 or example.com/your-alias? – Michael Yaeger Aug 26 '16 at 18:39
  • Please explain your process for "when we do open the site to the public". I think it is unclear how you have accomplished this. – BodgeIT Nov 18 '16 at 17:52
0

It seems that you are blocking access to the public using an .htaccess rule and also using configuration settings.

Go to the "System" - "Global Configuration" and, in the "Site" tab, change the "Site Offline" value to "No". The reason why you were able to see the website when you are logged in is because logged in admins can still see the website even when it's set to be offline.

  • Thank you! When I change the site offline value to No that is when the site gives a 404 error. We are using the default htaccess file that came with Joomla 3.5. We made no changes to the htaccess fileat all. – user8874 Aug 16 '16 at 14:14
  • Try renaming .htaccess to .htaccess.old - just to make sure that this has nothing to do with this. – itoctopus Aug 16 '16 at 14:16
  • Ok. Thanks. I tried renaming the htaccess file as you suggested but no luck. Still the same. I appreciate your help. – user8874 Aug 16 '16 at 14:20
0

It sounds like your default "Home" menu item (marked with a star in the list of menu items) is set to the wrong access level.

Make sure the menu item is set to "Public" access.

Access level

In addition, if the menu item points to a single article, the article must also be set to public access.

Update:
It's also possible that there is a problem with your ACL (Access Control List) settings, since the page works fine when logged in as administrator, but not for guest users. It's hard to say exactly what's wrong without seeing the site, but if possible I suggest creating a separate installation of Joomla and compare the settings.

Here are some places in the admin area where you might want to check the settings:

  • Users → Manage → (Options button in upper right corner)

    Make sure "Guest User Group" is set to "Guests"
    Guest user group

  • Users → Access Levels

    Check that your viewing access levels are similar to this screenshot, particularly for Public and Guest:

    Access levels

  • Check if you have any third-party extensions installed that affects access levels, like membership extensions or similar. If so, disable the extension in Extensions → Manage → Manage (don't uninstall, just disable by clicking the green checkmark.

  • Update Joomla and all your extensions.
    This might not solve the issue, but you should always use the latest version of Joomla (currently 3.6.2) and all extensions, they contain security and bug fixes.

  • Hi Thanks for the suggestion. I just checked and the default home menu item is set to public. All articles it points to is also set to public as well. – user8874 Aug 16 '16 at 14:56
  • OK. Check your categories too, just in case. Are you able to visit other pages (by typing the URL directly)? The link to your login form, for instance, is yourdomain.com/index.php?option=com_users&view=login – johanpw Aug 16 '16 at 15:01
  • HI I checked categories too, all set to public. Every page I try to go to direct also gives me a 404 error when site is open to public. – user8874 Aug 16 '16 at 15:10
  • @user8874 Please see my updated answer for a couple of ideas you can try. – johanpw Aug 16 '16 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.