0

I do have a weird issue with my Joomla 3.6 page. All works fine except the search. It works with several words but unfortunately it stops working with a total white blank page (even no HTML-markup).

I tryed debugging like here with no solution. There is no entry in my error.log. My access.log shows me

[27/Jul/2016:15:21:28 +0200] "GET /suche?searchword=edi&searchphrase=all&limit=20 HTTP/1.1" 200 430 "/suche?searchword=vendoc&ordering=newest&searchphrase=all&limit=20" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36"

Nothing special so far. It only appears to happen to certain words (no offensive words).

EDIT:

Under "plugins" there is just the "content" and "contact" enabled. If I disable "content" then everything works just fine. Under "components" -> "search" search statistic is logged with state enabled.

  • White screen means there is a PHP error but you have error reporting turned off. In your Global Configuration, set error reporting to development, then report back the error you get when trying again – Lodder Jul 27 '16 at 14:05
  • @Lodder no error is reported and it is just on random words – webprogrammer Jul 27 '16 at 14:32
  • Are you using search or smart search? If smart search, do you have gather statistics enabled? Are you using any search filters? – YellowWebMonkey Jul 27 '16 at 16:19
  • @YellowWebMonkey where can I find out which one is used? Under components "statistic" is enabled everything else disabled. Under plugins there is just "content" and "contacts" enabled. If I disable "content" everything works just fine. So the issue has to be related under "content" – webprogrammer Jul 28 '16 at 6:14
  • From your edit, you are using regular Search. Any change when disabling statistics? Since your error_log is empty, you might want to check that your php.ini is set to write to it. – YellowWebMonkey Jul 28 '16 at 13:45
2

Can you try setting up an alternate page using Components->Smart Search? This might help narrow down whether it is a code problem or server/resource problem.

If it is a code problem, check your template's override folder (/templates/TEMPLATE_NAME/html/com_search/) to see if there is a template override causing the problem.

1

Most likely this is caused by your script timing out on certain words, or your memory limit being exceeded on certain words (because they are in so many entries). I suggest you increase the PHP memory limit in your php.ini and see if that solves the problem. If it doesn't, then try increasing your PHP timeout in your php.ini.

  • It doesn't seem to be a timeout. My memory limit is at 128MB and timeout on 60s. – webprogrammer Jul 27 '16 at 14:41
  • Double your memory limit to 256MB and check if that solves the problem. – itoctopus Jul 27 '16 at 14:41
  • no changes happening - even when increasing to 512MB – webprogrammer Jul 27 '16 at 14:51
  • Are you sure that your changes are taking effect? Also, are you on a VPS or on a shared host? – itoctopus Jul 27 '16 at 14:54
  • It's my machine and changes take affect - yes. I can override via .htaccess. I inserted the memory limit on first line then i made an echo on phpinfo - so yes it tells me 256MB – webprogrammer Jul 27 '16 at 14:58
0

This solved the Joomla White screen of death for me:

in: plugins/content/phocagalleryslideshow/phocagalleryslideshow.php add the line:

if(!defined('DS')) define('DS', DIRECTORY_SEPARATOR);

just before:

if (! class_exists('PhocaGalleryLoader')) {
    require_once( JPATH_ADMINISTRATOR.DS.'components'.DS.'com_phocagallery'.DS.'libraries'.DS.'loader.php');

I got a hint that this module was causing the problems by setting in configuration.php the error reporting to maximum.

public $error_reporting = 'maximum';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.