Hot answers tagged

8

Joomla uses PHPMailer as mail handler. PHPMailer has a nice SMTP log if you turn it on. You can do this by setting the SMTPDebug variable to true $mailer = JFactory::getMailer(); $mailer->SMTPDebug = true; $mailer->setSender($settings->sender); $mailer->addRecipient($settings->to); $mailer->setSubject($settings->subject); $mailer->...


6

If it were me, I'd do this: Sign up for Mandrill (made by the MailChimp people). You get the first 12,000 message for free. Sign up here: https://mandrill.com Get the CMandrill component from CompoJoom for free. Get it here: CMandrill Follow all the CMandrill instructions. It bypasses the entire Joomla mail system and sends everything through Mandrill. At ...


3

You need a valid smtp server account in order to be able to send emails through SMTP. Your configuration settings show: SMTP Host = localhost SMTP User = ''; // none, empty SMTP Password = ''; //none, empty Since I see localhost for the host, I assume you want to use the smtp server of our hosting account. In this case you need to ask your ...


2

This issue is because Google have locked down their email system and require's apps to be authenticated first. With Joomla! this isn't possible at present, so you need to enable the 'less' secure option on your gmail account. See: https://support.google.com/accounts/answer/6010255?hl=en Once done, set SMTP Security to TLS and Port to: 25 with ...


2

Found the problem, the server had the fsockopen() function disabled for security, which PHPMailer 2.1.4 (included with Joomla 2.5) uses. The issue was not present on Joomla 3.5 sites, as these use PHPMalier 2.1.14, which does not use this function. Removing the function from the disabled_functions section of php.ini restored the email functionality to all ...


2

Ah, I've found it: AddCustomHeader(). Output looks OK like this: $body = "Some content"; $mail = JFactory::getMailer(); $mail->addRecipient("recipient@example.com"); $mail->setBody($body); $mail->setSender(array("sender@example.com", "John Doe")); $mail->setSubject("My Subject"); $data = array( "options" => array("transactional" => "true") ...


2

Some hosts blacklist SMTP mail servers and the PHP mail setting just never consistently works. We ended up having to use mandrill's API http://mandrill.com/. There is an exellent extension to use the API instead for all mail on your site. CMandrill. https://compojoom.com/joomla-extensions/mandrill-transactional-emails-made-easy This of course cannot use ...


1

If you're 100% sure that everything is OK and that the problem is not because of your host (a firewall setting), then the likely solution is to enable less secure apps. Read here for a guide on how to do this.


1

I also noticed your password and username were empty in the configurations you posted: essentially, you do not actually have SMTP and as Michael's warning states, your previous host was actually just allowing you to send without any authorization and creating a security vulnerability. A host will have documentation on their SMTP requirements and settings. ...


1

Option 1: In order for you to use the SMTP option in Joomla! on your local installation, you will need an SMTP service installed on that PC listening to port 25 (or whatever port you assign). If you do not have an SMTP service running on your PC (which you likely do not), you can change: public $mailer = 'smtp'; To: public $mailer = 'mail'; This will ...


1

IMAP/SMTP do not work be default with Gmail accounts. Probably need to enable less secure apps: https://support.google.com/accounts/answer/6010255?hl=en


1

There 2 things to check: first of all is email count registration is completed - some services requests additional data filled at account before it can send email (spent 5 hours to find this issue once) second - is there right authentication protocol chosen in Joomla mail server configuration


1

If Joomla receives a code associated with a successful delivery, then it was delivered. If it does not reach the target, then there is something wrong in mailing configuration.


1

Local hosts do not support emails unless you manually install and configure the required tools, which is quite a fussy task. Thus, to test your emails, I'd suggest moving your site to a live server instead.


1

Your site is going to send mails following your configuration on Global Configuration/ Server/ Mail Settings. For SMTP, you have to select Mailer=SMTP and the rest of the required information, e.g. SMTP Host


1

Sign-in with your google account, and Click Here now on the bottom right you will find Allow less secure apps: OFF Some non-Google apps and devices use less secure sign-in technology, which could leave your account vulnerable. You can turn off access for these apps (which we recommend) or choose to use them despite the risks. Turn it on and now you will ...


1

Try these settings : Mailer : SMTP Server Mail from : youremail@yourdomain ( Write your e-mail here ) From Name : My Name ( Write a normal name here ) Sendmail Path : leave it by default SMTP Authentication : No SMTP Security : None SMTP Port : 25 SMTP Username : youremail@yourdmain ( Your Full e-mail address ) SMTP Password : YourEmailPassword SMTP Host : ...


Only top voted, non community-wiki answers of a minimum length are eligible