We’re rewarding the question askers & reputations are being recalculated! Read more.
9

In this I will explain how to set this up for Wampserver 2.5 with Apache 2.4+. Once you have downloaded, installed and started Wampserver, go to the following directory on your computer and created a new folder called "joomla" C:\wamp\www Within your newly created folder, extract the Joomla zip file. Now that you have your new folder with the Joomla ...


7

I've just did this with OSX and here's how; All websites on OSX are stored in users/sites Step 1 Create a new website folder called 'joomla' cd ~/Sites/ mkdir joomla Step 2 Now add a new record to Apache's host file - edit httpd-vhosts.conf file normally located in private/etc/apache2/extra/ Add the following to the file (change names accordingly); &...


7

Instructions for Linux OS with Apache 2+ Server: Edit the file /etc/hosts and add this line: 127.0.0.1 joomla Create a .conf file like joomla.conf inside the /etc/apache2/sites-enabled directory, then open it and add these lines: <VirtualHost *:80> ServerName joomla DocumentRoot /var/www/joomla <Directory /var/www/joomla> ...


4

Good answer provided by @Johanpw. Personally, what I always do is open the htaccess.txt file in a text editor. For me, I tend to use Notepad++ for simplicity. Once done, simply go to File >> Save As (CTRL + ALT + S) and name the file .htaccess. Job done


3

if you have acces to the backend, try disabling the SEF configurations. EDIT: then you have an issue with rewrite rules, check with an original .htaccess (cf joomla installation package) after that you can reenable SEF as it should work xampp.


3

In Windows Explorer, the path of least resistance is to select the file then press F2 to rename it (or right-click and choose Rename), then rename to: .htaccess. Notice the trailing dot (.), make sure you add that too. Hit enter and confirm that you want to rename the file and voila: (I have a monkey head icon because I've got Helicon Tech's APE installed....


3

Joomla 1.5 was not developed for thes like of newer PHP versions such as 5.4 as mentioned in your question. Newer versions of PHP may have deprecated or even removed/replaced functions which Joomla 1.5 may require. I would suggest installing PHP 5.3.x on your Xampp installation, then try running the installation again. Personally I would use Wampserver ...


2

Background As the message confirms, Windows does not allow empty file names. The .htaccess file is used on Linux systems, and the dot (.) in front of the name is used to make it a hidden file. However, Windows files consists of a name (before the dot) and a file type (after the dot), thus interpretting the "name" of the file as empty, and the file type as ...


2

This is just an addition to the excellent answer from @Lodder. This is slightly offtopic but offers another approach to avoid this kind of issues. Nowadays one of the preferred (call it popular) approaches to development is running virtual machines on your PC that mirror as much as possible the configuration of the production server. For example you ...


2

First of all, you don't need to download the latest version of Joomla, because the files you download from your original site already has everything you need. Akeeba Backup is a better way to move/restore a site, but as you say you don't have full admin access, it's not an option. You'll probably have to get full admin access eventually, but that's not very ...


2

Almost every time there is a blank page on a php application, it denotes a php fatal error somewhere. It's not uncommon, it happens and there can be many reasons for it. Troubleshooting tips Error reporting First of all, you have to enable Error Reporting, so Joomla/php will print any errors in your browser. This way you will get an idea of what's ...


1

There is a plugin called n3t coming soon which may help you with this. When enabled it will show a coming soon page (which you can customise if you like) while letting you view the site. It uses your IP address to decide whether you can see the site or not. https://extensions.joomla.org/extension/n3t-coming-soon/


1

So why not just set the page in the joomla configuration to „offline“ or did i missed something in your question? Its exactly for this purpose.


1

This issue happened to me and I solved it by disabling the "language filter" plugin. I hope it could help someone. :) Cheers!!


1

Try disabling your .htaccess file and see if that helps. If that doesn't help, then you are likely using an SEF plugin that is causing this mess. If disabling (renaming) your .htaccess file fixes the problem, then this might be caused by 1) a hardcoded redirect to https when your Joomla website is already doing that or 2) a wrong redirect rule.


1

The problem was caused by the site URL being set as the live site rather than the local installation in MAMP, I set it to the local URL and now the site works


1

An .htaccess file from a live environment may contain many directives that cannot work in another environment, especially a localhost environment. In your case, I would guess to look for the # RewriteBase /, that according to your root directory localhost/3i, it should be: # RewriteBase /3i. update: Actually, it needs to be uncommented like: ...


1

Changing Apache from port 80 to port 81, or anything else, should solve this issue without haveing to stop Apache.


1

Transferring sites between platforms can be tricky. As you discovered, Akeeba Backup (or similar backup extensions) simplify this error-prone task.


1

Maybe an active session (not closed properly) in the Joomla! sessions table is the error. Try this: Login to cPanel. Access the database using PHPmyAdmin. Delete all the user sessions from the sessions table.


1

By default, Xampp doesn't support a mail service which is what the Notice SMTP connect() failed error is associated with. If you feel comfortable enough setting it up, a good post was written here: https://stackoverflow.com/questions/15965376/how-to-configure-xampp-to-send-mail-from-localhost Else you will have to put your site on a live hosting ...


1

Local hosts do not support emails unless you manually install and configure the required tools, which is quite a fussy task. Thus, to test your emails, I'd suggest moving your site to a live server instead.


1

In the BE, navigate to System Information > Directory Permissions The status should be green for all folders / files, especially the tmp directory. If you see this as "unwritable" you need to change this. There is some good documentation about this in Installing Joomla on Debian Linux. See the section with Set ownerships and permissions.


1

It's undoubtedly a permissions issue, possibly because the user Apache is run under does not have sufficient privileges. If you're on OSX then I'd recommend you use MAMP instead, designed for OSX, it works out of the box: http://www.mamp.info/en/


Only top voted, non community-wiki answers of a minimum length are eligible