22

There are a few potential causes for file and folder permission issues on Linux hosting. 1. File and Folder Permissions Check folder permissions are set to 0755 and file permissions are set to 0644. Note that file and folder permissions can be reset to these standard secure settings on a site wide basis using the free or the paid version of Akeeba Admin ...


12

Please check the permission levels, it should be 644 and 755 for files and folders respectively. Many times the permission levels are just fine, even when some issues are faced. It means that you will have to check the the ownership and group of the specific files and folders. Normally the group and ownership can be changed to www-data for apache (used in ...


8

An easy solution for me is to often let PHP run in (Fast-)CGI mode and to set the ownership of the Joomla directory to the FTP user. So you will be able to upload and overwrite files via FTP and Joomla will be able to write files too. A way to do this on a shared hosting environment (if it is allowed), is to add something like this to your .htaccess file: ...


7

Permissions should be 644 and 755 as explained by Shyam. In Joomla you can avoid all the problems you mentioned ,with following methods. Not being able to transfer files to the server using programs such as WinSCP. This may happen due to permission of (444) like Joomla configuration.php have this permission its doesn't allow by default(for security). ...


7

Permissions should be 644 and 755 as explained by Shyam. The problems you are facing are most likely related to the way your server is set up. Most of the time this happens on shared hosts where Apache runs under a different user than your FTP account. Since you usually upload Joomla using FTP, Apache isn't the owner of the file and thus doesn't have the ...


5

Yes, the permissions should be 644 and 755 as explained by Shyam, but the other posters forget to mention that this is if the file is owned by your webserver, and the group is the group you belong to. For instance, in FileZilla you will see permissions something like this: Filename Size Filetype Last Modified Permissions Owner/Group ...


4

The other answers provides a good explanation of what should be done, I only want to add a script to fix the permissions if you already uploaded a component and can't access the files with ftp. In this case I would upload this file as fix.php to the FTP server and open it in the browser: http://example.com/fix.php <?php file_fix_directory(dirname(...


3

Obfuscated File Name You can upload a file to the website e.g. at website.com/obfuscatedfilename.pdf and then notify users of the file location via email. Users can then download the file by browsing directly to it and selecting the option to download the file. Restricted Content You could add the link to an article and only allow access to the article ...


3

It's likely you'll want to change ownership to user www-data. You can see the user assigned to that space by doing # cat /etc/passwd. Always be careful when touching objects as root. You can break a lot of things.


3

The fastest way to check whether your Joomla!-installation has the necessary permission, is the built in function: Just go to System->System Information->Folder Permissions, which should look something like this: There you can see exactly if it is a problem with your permissions, or something else.


2

You need to have logged in as only one user when you uploaded the site. Two different logins means two different permissions. This is a precaution to safeguard two different users files from being overwritten. It has nothing to do with joomla, it's your shared server. Log in to your control panel, use the file manager to zip up joomla and download it to ...


2

No, all of your folders should be set to 755 and files should be set to 644. With Joomla, the only file that should ever need to be different (optional) is your configuration.php file which can be set to 444


2

If you're using Apache, you can also make a directory indexable by editing the .htaccess file in that directory. Just make a file in your directory called .htaccess. The file should contain the following (and whatever other apache options you want): Options +Indexes


2

To set files and directories to chmod 777 or even chmod 770 is not a good idea on a production system. Every webserver system like apache2, nginx can be configured to work with a special user and group - that's important not to get any user rights on the system. On most Debian like systems, the user is set to www-data with group www-data, standard is the ...


2

SELinux was my problem. I was able to write to the directories once I set it to permissive mode. sudo setenforce 0 However I did not want to disable it entirely as set out to correct the issue. Following the steps from CentOS on SELinux I was able to determine the correct context for the folders/files that should be writeable. While in permissive mode I ...


2

By default, the file permissions on Joomla extracted files are 644 and the folder permissions are 755. If you're seeing something different, then, as @jdog mentioned above, you will need check your umask settings (if you have a system administrator then I suggest you let him handle this). umask is used to remove deny default permissions (it is not used to ...


2

Maybe check your PHP fpm configuration. This answer describes how umask is set https://stackoverflow.com/a/21319941/123594


1

Are you getting the white screen with the message for the sql, or the Joomla system page with the outdated links etc? I would make sure the restoration on the new server has been done without errors. I mean, it can be some corrupted files. If it's a site that you have built, then you know about what extensions you are using, but just in case make sure ...


1

From Joomla Forums: replace "$tag = $this->getLanguage()->getTag();" by $tag = JFactory::getLanguage()->getTag(); ok 100% working (could not do a proper quote and link to reference with a comment... so answer) Incidentally, the actual bug is apparently in some unknown extension you have installed. You might try using the debug mode so you can ...


1

Joomla must always have consistent directory permissions. For example, certain operations may have to save a warning in the log/ directory. You can check directory permissions in System Information/Directory Permissions. In addition, a blank screen is a PHP error page with PHP Error reporting in disabled state. Try to enable PHP Error reporting to show the ...


1

Maybe you installed K2 before deciding to use the FTP interface? When an extension is installed using apache interface all the files and directories created during the installation are owned by the apache user. Typically the FTP user will not have the write permission on them. The fix is to change owner to correct value. chown will fix this if you can use ...


1

Open your apache configuration file and add these lines of code: User apache Group root The file may be located in /etc/apache2 directory for example /etc/apache2/httpd.conf As an alternative you may consider changing the ownership of files/folders to www-data:www-data recursively because this is the default user/group of apache: chown -R www-data:www-...


1

I think this extension might work. The code doesn't appear to be file based, it's folder based, but you might be able to make it work. QuickDownload


1

It's undoubtedly a permissions issue, possibly because the user Apache is run under does not have sufficient privileges. If you're on OSX then I'd recommend you use MAMP instead, designed for OSX, it works out of the box: http://www.mamp.info/en/


1

In linux, you can find out the name of the user running Apache with a command : ps aux | grep apache # shows username in the first column Retrieve the groups this user is part of with the groups(1) command: groups [USERNAME] Here is a screenshot to find out apache [user-name] and [user-group] in Ubuntu 12.04


1

Late to the party. I came here looking as well as other places for a definitive guide on what folders need to be writeable for joomla. Sorry folks to be the harbinger of bad news. The advice to use the permissions 755 for all directories and 644 for all folders is irresponsible at the very least. Making all your folders and files owner writeable is fine ...


Only top voted, non community-wiki answers of a minimum length are eligible