Hot answers tagged

3

Depending on the purpose, there can be some advantages in using a CMS compared to a static HTML website and this is why Joomla has been downloaded over 80 million times as at March 2017. Updating Content Content is not stored directly in HTML files in Joomla but is usually stored in tables in the Joomla database. You could use a tool like phpMyAdmin or ...


3

This can be for one of this possible reasons: Your template uses some framework, like T3 or Helix, and you have enabled a feature that allows you to compile the code every time the page is reloaded. Solution 1: Check if you have this option enabled in Templates > Your Template Solution 2: Some template frameworks allows you to add another css file called ...


3

Make an override of com_content/views/form/tmpl/edit.php in your template and move this row: <?php echo $this->form->renderField('catid'); ?> in the <div class='tab-pane'> that you want. You can easily change the order of every field, just pay attention to keep this rows inside form and fieldset tags. Avoid editing the xml file, or on ...


3

The reason you can't edit the HTML files is that they don't exist. The whole point with a CMS is that each page is generated dynamically, based on your template, articles, modules, components etc. The source code you see in your code inspector is not stored anywhere, it's generated on the fly by Joomla when someone requests that page. I’ll try to give you a ...


3

Most probably your article editor (TinyMCE?) is cleaning up your code. This is expected behavior by default. Both <iframe> and <form> are among the tags that are removed automatically by TinyMCE. There are a couple of ways around this: Use Sourcerer, a plugin that lets you add HTML (and other kinds of code) directly inside your articles. There's ...


2

I think I have sorted out the conditions that make this issue appear, although I have not dive into the code yet. Just for information, this is a Joomla 3.3.3 multilingual website. The issue appears when an article has association with the corresponding article of the second language. Can anyone else test to see if he can replicate the issue? If I have time, ...


2

You didn't specified if this is happening during saving or right after it, or if your custom.css rules remain untouched until you perform an update to Joomla or your template. If you fall into the first case, I don't have an answer at hands right now. But for the the second case what you see happening is absolutely normal. Golden Rule: Never, ever modify ...


2

You can not include PHP code in articles. But there are extensions that will help you to achieve it, for example Sorcerer. Once installed, you can add your PHP code into your article like so: {source} <?php include PATH_TO_FILE.php ?> {/source}


2

The first and most important thing for you to know and understand is that Joomla! and all its extensions are designed to be upgraded by their developers with the upgrades then spread to all Joomla! installations using the built-in upgrade mechanism. Also understand that many of those upgrades contain fixes to severe security vulnerabilities, so that while ...


1

The free version of JCE does not support that, but Joomla's built-in TinyMCE does. Moreover, the built-in CodeMirror editor in Joomla! 3 does syntax highlighting. If you find that specific users spend most of their time editing raw HTML you can tell them to click on their profile at the top-right corner and switch their browser either to TinyMCE or ...


1

There can be javascript cache problems. Clear your browser/Joomla! cache first: https://docs.joomla.org/Help36:Site_Maintenance_Clear_Cache http://www.wikihow.com/Clear-Your-Browser's-Cache If that won't help simply reinstall Joomla! Keep in mind that all your CSS changes will override during reinstallation.


1

Does not seem to be easily possible, currently: https://github.com/joomla/joomla-cms/issues/7809


1

A few things to check. Make sure you using the latest version of the Joomla 2.5 series (2.5.28) Check to see if your server has mod_security installed. If so, then you should ask your hosting provider to disable it. If this is not possible, then try adding the following to your htaccess file: <IfModule mod_security2.c> SecRuleEngine Off </IfModule&...


Only top voted, non community-wiki answers of a minimum length are eligible