Questions tagged [joomla-mail]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
28 views

Internal Server Error on Send Test Mail

Im using Joomla 4.1.0 When i try to send a test mail, from Global Configuration - Server - Mail, i get the following error message. "An error has occurred while fetching the JSON data: HTTP 500 ...
2 votes
4 answers
340 views

Cannot send emails after migrating hosted joomla to localhost

I have trouble sending emails with Joomla! 3.6.5 I get a message Notice ??SMTP connect failed?? The settings in the configuration file are the same as the same ones as at the hosted website. public ...
2 votes
1 answer
51 views

Override Joomla mailer settings in case of using secondary mailserver as backup

Does anyone know how to "override" these mail settings in Joomla? I need to set host, port etc at PHP level: $mailer->setHost = "localhost"; $mailer->setPort = 25; $mailer->setSMTPAuth = ...
3 votes
3 answers
1k views

Use Joomla-Mailer to send mails in HTML and plaintext

I followed http://docs.joomla.org/Sending_email_from_extensions to send mails via Joomla!. Now I'd like to send HTML and plain text mails, because not all users want to receive HTML-formatted mails. ...
0 votes
1 answer
4k views

Can't Send Test Mail even the settings are correct

With reference to the subject mentioned above.. I've spent a couple days with these issue and can't find any answers anywhere. i'm able to change and save the global configuration settings. i'm able ...
1 vote
1 answer
313 views

sending mail from personnal component = ok with Joomla!3.4.5 but nok with Joomla!3.6.2

For debugging, I tried these lines: jimport('joomla.mail.mail'); $m = new JMail(); $m->SetFrom('myAddressMail@xx.fr','myName'); $m->AddReplyTo('myAddressMail@xx.fr','myFirstName'); $m->...
10 votes
2 answers
9k views

Fix the "Invalid Address" error, after upgrading to Joomla 3.5.1

After upgrading to Joomla 3.5.1, I get an Invalid Address error in some of my extensions that use PHPMailer (the Joomla Mailing system). How can I fix this?