0

I get this error appear on my website

Warning: file_put_contents(): SAFE MODE Restriction in effect. The script whose uid is 10072 is not allowed to access /var/www/vhosts/pizzaholicheaton.co.uk/httpdocs/cache/com_virtuemart_cats owned by uid 502 in /var/www/vhosts/pizzaholicheaton.co.uk/httpdocs/libraries/joomla/cache/storage/file.php on line 384 
Warning: file_put_contents(/var/www/vhosts/pizzaholicheaton.co.uk/httpdocs/cache/com_virtuemart_cats/index.html): failed to open stream: No such file or directory in /var/www/vhosts/pizzaholicheaton.co.uk/httpdocs/libraries/joomla/cache/storage/file.php on line 384

This appears on the front end and the back end (noticed it when making a category in VM3)

Its a new site, I deleted all contents from old website, and put Joomla 2.5/VM3 on. I did have it in a sub folder, but decided to just copy it over the old site before I started. However I get this. I set all permissions to 777.

I've read on the Joomla forum saying about caching, is this right? What should I do?

2

It's not a chmod permissions issue, but an issue with your server. Hosting providers sometimes enable safe mode on shared hosting environments to prevent you from screwing up thing for other users on the same server.

Safe mode was deprecated in PHP 5.3 and removed in 5.4 I believe.

If you have access to your php.ini file, you simply need to disable it like so:

safe_mode = Off

Else will need to ask your hosting provider to disable it

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.