0

I am in trouble from few days, suddenly I got js error "Uncaught TypeError: undefined is not a function" and it's point to megamenu initialization code. Few days back I have tried to uninstall the YT framework plugin and then re-installed it. And then I have noticed the js error. Because of this js error my local testing site does not functional well, most of the features are stop working. And the strange thing is everything is working correctly on my production site. I have tried to compare the yt framework plugin code of both production and testing server but both shows identical. Now I am clueless.

I am using Joomla 2.5.19.

2
  • Sounds like a JS conflict. Maybe the TY framework is importing scripts without using the Joomla API. Could you try installing the jQuery Easy plugin an see what the outcome is please
    – Lodder
    Apr 28 '15 at 8:28
  • @Lodder thanks for your suggestion, I have already installed the jquery easy but somehow I have disabled it on my testing server, your suggestion solved my problem, please make your comment an answer, I will accept it.
    – pkachhia
    Apr 28 '15 at 9:17
1

The error Uncaught TypeError: undefined is not a function is normally due to a Javascript conflict. With Joomla, it's most likely due to Mootools/jQuery or a script not being imported using the Joomla API and thus duplicates.

Try installing the jQuery Easy plugin to ensure only 1 instance of jQuery is loaded on your site and see what the outcome is.

Just on a side note, please update to Joomla 2.5.28 as you're quite a few versions behind, therefore haven't got the latest security, bug and feature updates

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.