3

I am attempting to use the JCE editor in Joomla 3 but when I have it enabled under my system settings, non of the edit icons appear.

enter image description here

I have tried this on Firefox, Chrome and Safari and nothing will have these edit icons appear. As you can imagine, it's quite frustrating trying to use JCE like this. Does anyone know of a solution OR a better editor?

  • Have you edited any core Joomla files or moved any CSS/fonts about? – Lodder Apr 26 '15 at 0:00
  • No, I have not. – Daniel Apr 26 '15 at 0:43
  • Can you open your browser console (F12) and see if any errors occur? Might be a file missing – Lodder Apr 26 '15 at 0:44
  • I'll try but I don't think that's the case. I have redownloaded the editor several times and it all ends up the same – Daniel Apr 26 '15 at 0:46
  • 1
    For bugs and other issues, there is a support forum at joomlacontenteditor.net. – FFrewin Apr 12 '17 at 18:57
4

Open developer tools on your browser (F12 on Chrome) and see if there are any 404 errors. Usually JCE loads buttons from one sprite located under.

/components/com_jce/editor/tiny_mce/themes/advanced/img/icons.png

The other possibility is some other style sheet on your site is overriding the buttons css. In your browser developer tools debug css of styles such as

.defaultSkin .mceIcon

and see what is the background property. It should be something like

.defaultSkin .mceIcon {
  background: url(../../img/icons.png) no-repeat 20px 20px;
}
1

I know this is an old thread but some of are still having this issue.

I found that it works if I do NOT use a secure connection, ie, "https" but just http.

I manage 2 sites on the same hosting site and there is no problem on one of them using either https or http so I must have a setting somewhere preventing the icons from showing in a secure connection.

David

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.