2

I have been recently assigned to take care of a website that uses joomla. First things I'm trying to do are "smaller", like posting or editing articles.

I've received a super user account, but even so, when I try to edit an article, I receive a "Forbidden access" message ("You don't have permission to access /administrator/index.php on this server."). After that, when I go back to the content administration page, the article is shown as blocked. I then unblock it, re-open, and the whole process occurs again, unchanged. This is happening a lot. So far, I have only tried with articles which contained images.

What I do know: the server isn't run by us, so I thought that there might be something related to access permissions to the folders, directly? If so, I must still understand what's going on, so I can ask for the right permissions.

To sum up the question(s): - are there any automatic mechanisms by which joomla can block articles? - if so, can I disable them? - could this be due to access permissions for the server folders, even though I'm a super user?

Thanks in advance!

EDIT: Still facing this issue, seems to be related only to articles that have images associated. Using our ftp I've managed to check that the images within the articles that I'm not able to edit have different file permissions (644 instead of 664) than the others listed. This doesn't seem to affect much the forbidden access issue. Thought the problem could be somehow related to image alignment, too, but no...

  • did you take a look into the system maintenance area? This section of the administration has a tab that shows information about permissions - you could check there if everything has the correct permission settings. You'll find it under System - Maintenance - File / Folder Permissions, I believe. – elk Apr 25 '15 at 5:28
  • Are you sure you have super user account? It might be that another ACL component is installed. Check in extensions manager, filter by component to see the list of components. Finally, it can be corrupted assets. Installing the component ACL manager could help debug and fix such issues. – FFrewin Apr 25 '15 at 12:32
1

A few things to check.

  1. Make sure you using the latest version of the Joomla 2.5 series (2.5.28)
  2. Check to see if your server has mod_security installed. If so, then you should ask your hosting provider to disable it. If this is not possible, then try adding the following to your htaccess file:

    <IfModule mod_security2.c>
    SecRuleEngine Off
    </IfModule>
    

Once done, rename your htaccess.txt to .htaccess

  • 1. We're still using an older verson of Joomla 2.5.7 Stable. My colleague said he had trouble trying to update it, maybe I should try solving that first...? 2. Tried that. The result is that I wasn't even able to open the articles.... =/ – Jufajardini Apr 28 '15 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.