3

My Joomla version is 3.4.1 I'm working with a template named TZ Simple Love. I've installed this template, it was correctly showing in the Template Manager list. One of my site admin accidentally deleted this. Now I want to install that again, but problem is that, when I am trying to install it; Joomla showing the template is installed. But when I click on the Template Manager the template is not in the list !!!

Not only this, if I click on the filter on the left column, it is listed there. If I select it from there, it shows :

There are no styles installed matching your query.

How can I solve this weird problem.

  • When you say, he deleted it, do you mean deleted or uninstalled it? – Lodder Apr 21 '15 at 12:46
  • If one or both of the answers below solved your problem, please award the green tick to the answer that you feel is best. If neither solved the issue, please update your question with where you are stuck and notify the volunteers that offered support so far. – mickmackusa Feb 2 at 7:06
3

You should take a look at the database. Look for your template in the #__assets and #__extensions tables and delete it. Then try a fresh install of your template.

I guess the problem is that you deleted the files from the server, but not the entries from the database.

I also suspect that if you try fixing the database from Joomla's administrator panel, Joomla might do it automatically, :)

2

Try installing the template manually by uploading the template files to ROOT/templates/tz_simplelove_joomla/. Create the directory if it doesn't exist, and overwrite any existing file if it does.

Now discover the template by going to "Extensions manager -> Discover" (more details here). You should be able to re-install your template.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.