2

I have a Joomla 2.5 website. The website requires all users to log in as the content is restricted to registered users.

When my users log in there is a Remember Me function as part of the core Joomla system. This doesn't seem to be working properly for users that have checked this.

I found a question on here that looked like it was having the same issue: https://stackoverflow.com/questions/11956186/remember-me-plugin-is-not-working-on-joomla2-5/29745525#29745525

From that question, I have created the phpinfo.php file (as the cookies lifetime was set to 0 by my server) and set it to 30*24*60*60 (30 days). I had tried adding "ini_set('session.cookie_lifetime', 536*60*60);" to the index.php file within the Joomla folder too but it didn't work. Any ideas?

  • Have you ensured you're using the latest version of the 2.5 series (2.5.28)? – Lodder Apr 20 '15 at 12:34
  • Yes buddy, I have the latest (and last) version installed. – user3711642 Apr 20 '15 at 13:04
  • Did you verify that the value for session.cookie_lifetime has changed? – fruppel Apr 21 '15 at 7:18
  • Yes @fruppel, the value within the phpinfo.php file says "2592000". – user3711642 Apr 21 '15 at 8:33
  • It seems to work now. After trying a few different ways to test and fix the way I "think" it fixed it was to enable Joomla Authorisation. The extension I was using to allow users to log in using an email address rather than a username suggested to turn off Joomla Authorisation but after I turned it back on it seemed to fix the Remember Me issue. Thanks. – user3711642 May 13 '15 at 9:57
2

In the global configuration settings for Joomla there is a Cookie Domain setting - be sure this is set. Also be sure that you are accessing the site consistently. If you have set the domain to be for www.yourdomain.com but you access at just yourdomain.com, the cookie may not be present. Another consideration is when using ssl versus non-ssl.

2

I have had a similiar problem. And the solution was to configure better JCHoptimize. In my case it was a javascript conflict.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.