2

I am trying to replicate the com_contact contact form page using Seblod CCK. My goal is to display contact person and then below give the user the ability to submit a request.

I have already created several content types so I roughly know how to use Seblod, but I am new to creating contact forms. Here are the steps I have done:

  1. Created a new app folder for my contact form
  2. Created a new content type for the contact form
  3. Added the fields that I want the user to fill in such as (name, email, message) and a submit button. Choosing storage location as None so it does not get saved into the database.

Then I assigned a menu item to the contact form choosing access level as public. When I open it, instead of the contact form, I see login prompt. It seems I am not allowed to view the contact form as anonymous. Who do I set the permission such that anonymous users can view and submit my contact form.

  • This site is still pretty early, so you can suggest new tags by adding them, even if they don't exist yet. You could (and I think are) the first to ask questions on these topics! – David Fritsch May 20 '14 at 21:28
1

The right access level for your case is Public, unless you have done any changes to the default ACL structure. If you haven't done such changes, then you should check the permissions settings you have applied into your form.

Check to see if there is public access for creating new submissions (or other similar options) in your form.

Seblod Editing Permissions

  • Its already set the menu access to public and I have not changed the default ACL structure. I could not find an option in Seblod that controls access for forms. – lanoxx May 21 '14 at 11:33
  • Check the updated answer, it contains a screenshot with where to find the permissions sections in seblod. – FFrewin May 21 '14 at 11:58
3

I found the answer my self in a SEBLOD blog entry. There is a small arrow at the right corner of the content types main settings.

enter image description here

When opened there is a permission button:

enter image description here

And in there I could set the Create permission for the group Public to Allowed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.