2

I use Netbeans for Joomla extensions development, I want to stick to Joomla coding standards but I have a problem with the first phpdoc comment block.

I know this is an stupid question but it's driving me crazy.

I can't configure first blank line after first comment when using Netbeans code auto formatting, when hitting SHIFT + CMD + F I get this:

<?php
/**
 * @package     Package
 * @copyright   Copyright (C) Owner. All rights reserved.
 * @license     GNU GPLv2 <http://www.gnu.org/licenses/gpl.html>
 */
defined('_JEXEC') or die();

I haven't found the way I can achieve this:

<?php
/**
 * @package     Package
 * @copyright   Copyright (C) Owner. All rights reserved.
 * @license     GNU GPLv2 <http://www.gnu.org/licenses/gpl.html>
 */

defined('_JEXEC') or die();

Note the blank line between the comment block and the first php line

Does anyone else use this feature of Netbeans to format code PSR-2 style? Did you solved this Netbeans issue?

2

Even though, I use Eclipse for development. This link may guide you to look for similar preferences in Netbeans to configure the tool.

https://docs.joomla.org/Configuring_Eclipse_IDE_for_PHP_development/Linux#Configuring_the_editors

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.