0

I recentely undertook the task of upgrading a friends site from Joomla v2.5.28 to Joomla v3.4.0. Thankfully the upgrade went smoothly and there was not many issues with incompatible plugins, components or modules.

Anyways, whilst testing out the site functionality to make sure it was working as it should I noticed that on the administrator dashboard when I attempt to:

  • Save an Article
  • Save & Close an Article

The sytem hangs on a blank screen with this url:

http://www.mytestsite.com/administrator/index.php?option=com_content&layout=edit&id=301

If I refresh the page the page displays as normal and I can see that the changes have been applied. I'm wondering if the blank screen is the result of some sort of file permissions error or PHP error?

I initially had an issue where the Save and Save & Close buttons were not working but I resolved this by setting the permissions of the directories and files to 755.

I'm guessing it might be related to some PHP issue but the fact that the changes are being applied makes me think different.

Anyways, I'd appreciate any help you guys might have

EDIT: I've just switched my error reporting to maximum resulting in this being output on the blank page:

Fatal error: Call to a member function getTag() on a non-object in mytestsite.com/libraries/cms/application/site.php on line 328

I will continue to look into it but would appreciate any input thanks.

1

Joomla must always have consistent directory permissions. For example, certain operations may have to save a warning in the log/ directory. You can check directory permissions in System Information/Directory Permissions.

In addition, a blank screen is a PHP error page with PHP Error reporting in disabled state. Try to enable PHP Error reporting to show the underlying error.

EDIT: The error seems to be related with a multi-lingual misconfiguration https://www.willows-consulting.com/Joomla/fatal-error-gettag-with-joomla-3-2.html

  • Hey @Anibal thank you for your response, I managed to find the issue after turning on Error reporting. Although the situation was not idea as it invovled me having to make a change to site.php. – Javacadabra Mar 16 '15 at 14:38
  • 1
    Less than ideal. A core file will be replaced in the next update. Check the link in the answer. – Anibal Mar 16 '15 at 14:39
  • Yes, I realise that. Unfortunately the above did not resolve my situation, I tried disabling the language-filter plugin but the error remained. I'm wondering if in this instance it would be safe to edit the core file because perhaps when it is replaced in the next update this issue is rectified. – Javacadabra Mar 16 '15 at 14:58
  • In your site, the issue may be caused by the upgrade . Upcoming 3.4.1 most probably won't solve a configuration problem. – Anibal Mar 16 '15 at 15:44
1

From Joomla Forums:

replace "$tag = $this->getLanguage()->getTag();"

by $tag = JFactory::getLanguage()->getTag();

ok 100% working

(could not do a proper quote and link to reference with a comment... so answer)

Incidentally, the actual bug is apparently in some unknown extension you have installed. You might try using the debug mode so you can get a trace and isolate the extension and maybe update or replace that.

I'd guess it would be a content plugin?

  • Why is this change not made in core already? – Olle Härstedt Jan 23 '17 at 14:31
0

A hard refresh solved the problem for me. i clicked the shift button + Refresh icon on my browser. i then clicked on the buttons and alas they now work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.