1

We are trying to run our Joomla site locally but are having issues with paths to things like images etc. We copied our site/database down from SiteGround and set it up locally in folder xampp/htdocs/DemoOrg and the site functions fine but all the paths to images etc are failing.

On Siteground the path to an image is set as "/images/ReportLog.jpg" and it displays but locally it doesn't display. If we do F12 and add /DemoOrg/ to the beginning of the path the image appears.

We need the site to function in the same way as on SiteGround so cannot add "/DemoOrg/" to the paths manually otherwise we would have to change code everytime we downloaded/uploaded the files.

Is there a setting that will solve this - someone has suggested in the hosts file but not sure how to do that.

Thanks Richard

  • How are these image paths being set? Is this in articles or in something that you are coding? – David Fritsch Mar 16 '15 at 0:39
  • sawmac.com/xampp/virtualhosts might help. Using vhost is bit of a cheat as it really should not be necessary for Joomla!, but it might not be worth the time to find the actual problem. Do you have any SEF plugins, if you do, disabling them while on local server might help. – Ville Niemi Mar 16 '15 at 7:47
  • 2
    I'm 99% sure that using a Virtual Host will solve this issue. It may not be required but I for one will always recommend it and use it for all local sites. We started writing some tutorials here: joomla.stackexchange.com/questions/4156/virtual-host-for-joomla – Lodder Mar 16 '15 at 8:19
  • Lodder Followed you instructions and it worked a treat Thanks – PerryW Mar 16 '15 at 11:33
  • Can you mark as solved please @PerryW – jonboy Apr 27 '15 at 8:43
2

Followed Lodder's instructions on how to set up a virtual host here:

Virtual host for Joomla

which solved the problem for me

1

Are you using xampp to run this locally?

The reason this is happening is in apache your root domain is set to

/htdocs/ (or something like that) 

Change it to

/htdocs/DemoOrg/

Leave the live site option as blank, that should fix it.

-1

In the config file /configuration.php search for "live_site" and set it to "". save and refresh in your browser.

Set all SEF options to no in configuration panel.

  • I've checked the configuration.php and live_site is already set to "". – PerryW Mar 15 '15 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.