This is a bit of a long shot, but I've posted the following question on the Joomlapolis forum a couple of days ago & so far no response.

I'm using Joomla 3.4 & Community Builder Pro 2.0.7. I am trying to get the registration so I can use the email address as the username. On Configuration > General I have Login method set to Email Address, on Configuration > User Profile I have Username Fallback set to Email, in Field Management username is not required & not shown on Profile, Registration, or Edit. From what I've read on the Joomlapolis forum that should make the username populate from the Email field, but it isn't working.

I've also tried using CB Auto Actions to set the username field to email on both Start Save Registration and After Frontend Registration, but whatever I do I just get the following error message: "The username '' is already in use."

Can someone tell me how to make this work? I know that Community Builder is supposed to be able to do this out of the box, but I'm just going round and round in circles here. I'd rather not hack the code as the client needs to be able to update the components when patches/updates are released.

  • 1
    I'm voting to close this question as off-topic because the issue was due to an unexpected occurrence in a database table. The issue could not be reproduced. – mickmackusa Feb 3 '19 at 2:05

Username and Email are different fields. According to my experience, you can customize your site to have Email also in username field and keep a consistent interface to avoid confussions:

  • Authentication - EMail plugin, to access with the email http://extensions.joomla.org/extension/authentication-email
  • Create language overrides, to replace the username word: COM_USERS_LOGIN_USERNAME_LABEL=Email
  • Some forms may have to be modified to avoid asking Username and Email
  • Even, if at the end of the day you detect an inconsistency, you can just run a query to overwrite all usernames with Emails
  • Turns out that the existing user table had an empty username in it! Once I found that & corrected it everything has been working as expected. – KarenB Mar 17 '15 at 9:21

You make this too complicated: keep it simple. In the configuration of CB on the first page, select "Username or Email Address": configuration setting

As login module select the cblogin module, and publish this as your login module: enter image description here

That it. No need to do anything more.

Greetings, Paul

Not the answer you're looking for? Browse other questions tagged or ask your own question.