3

I am manually translating some language files from en-GB to ca-ES (just the front-ends). Once translated and properly renamed, I place them in language/ca-ES but they are not picked up by my Joomla system. Am I missing something? It's happening all the time, so I guess I am. Can you help? Thanks!

Dani

  • I assume you are either setting the default language to Spanish or have a language switcher option available? – Lodder Mar 12 '15 at 16:50
  • Yes, also the files are saved as UTF-8 without BOM – Dani Valverde Mar 12 '15 at 17:12
  • Did you enable the language file debug in BE? – Valentin Despa Mar 12 '15 at 20:03
  • No, I haven't. I'll try it Valentin – Dani Valverde Mar 12 '15 at 20:04
2

Enable language debug to see what is going on.

The problem could be that your template has language override. So check your

/templates/template_name/languages

folder to make sure.

| improve this answer | |
1

Any typo, a missing or an unescaped link for example, will mean the whole file is ignored so you should check that. You can check if the file is being picked up, or not, with just a single entry of course. If it does work with a single simple entry then you have a typo somewhere in your full version.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.