3

The easiest way to see my problem is to check this site with SSL: https://www.rekuperatory.pl/zapytanie-ofertowe on two browsers, one being Firefox.

The thing is, it loads correctly in Chrome, IE, Opera, but in Firefox it fails to load CSS files. There's no issue when visiting the site via HTTP: http://www.rekuperatory.pl/zapytanie-ofertowe - it loads just fine on every browser including Firefox. The problem is only with Firefox, only via HTTPS.

When I contacted hosting provider, they assured me, that everything is all right with SSL Certificate and the problem must be in linking files. But I don't see how may I change this. My stylesheet files are added like that:

defined('_JEXEC') or die;
$doc = JFactory::getDocument();    
$doc->addStyleSheet($this->baseurl . '/templates/' . $this->template . '/css/default.css');

The funny thing is that when I run JCH Optimize, CSS files from template start working, but unfortunatelly the ones from custom modules don't. In modules there is slighly different way of adding CSS files. For example:

$doc->addStyleSheet( JURI::root(true) . '/modules/mod_mapa/css/style.css' );

I'm using Joomla! 3.4 but the problem was first seen on 3.2

closed as off-topic by Nils Rückmann, TryHarder, Dmitry Rekun, johanpw, GDP Apr 6 '15 at 19:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Joomla! administration and development, within the scope defined in the help center" – Nils Rückmann, TryHarder, Dmitry Rekun, johanpw, GDP
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What happens if you disable SEF URL's ? – Lodder Mar 11 '15 at 22:08
  • Have you also tried following the instructions given in this answer: stackoverflow.com/questions/17986572/… – Lodder Mar 11 '15 at 22:10
  • Disabling SEF URLs doesn't change a thing. Enforcing SSL frm admin panel also doesn't help. – zorza Mar 11 '15 at 22:21
  • Hmm odd. I remember there being a bug in Firefox with SSL and assets being loaded. Are you sure you're using the latest version of Firefox? – Lodder Mar 11 '15 at 22:30
  • 1
    Turns out, it wasn't Joomla's fault. I've recreated an issue with static HTML file. Fortunately, I've found a cause - .htaccess entry responsible for browser cache. You can find more on the topic here: stackoverflow.com/questions/29003838/… – zorza Mar 12 '15 at 13:47

Browse other questions tagged or ask your own question.