3

I need to update my joomla website which current version is 2.5.28. Now I'm trying to update it using this:

  • I use XAMPP as a server environment (PHP 5.4, MySQL 5.6)
  • Use a backup of my site
  • Also use astable version of joomla 2.5.28

I tried to update with both sites, the stable one and my one, but every time I get errors.

If I want to update my site I do this:

  • check for updates and update all things but for the JSN air template
  • go to joomla update, click on options on the right side and choose short time support, save and close
  • click update button

With the stable site I nearly do the same:

  • go to joomla update, click on options on the right side and choose short time support, save and close
  • click update button

I said above that I get errors. If I want to update the stable one I get these results/errors:

after updating it completely (100%) I get a white page with an url like "http://localhost/stable/administrator/index.php?option=com_joomlaupdate&task=update.finalise"

if I reload the page after getting the white page I get an error like "Can't DROP 'usertype'; check that column/key exists SQL=ALTER TABLE bcyqr_users DROP KEY usertype;"

if I reload the page again I get an error like "Table 'stable.bcyqr_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM bcyqr_postinstall_messages" I looked in the database and I haven't a column with name "usertype". What happened?

I think it's strange that it doesn't function with the normal joomla settings. On youtube I saw videos in which the people just did the steps I also did.

And with my site I get the following errors:

  • 18 times: Use of undefined constant DS - assumed 'DS' in C:\xampp\htdocs\mysite\administrator\components\com_poweradmin\defines.poweradmin.php
  • 1 time: Class 'JSNConfigHelper' not found in C:\xampp\htdocs\mysite\plugins\system\jsnpoweradmin\jsnpoweradmin.php

I googled that error, so I used this extension: http://digitaldisseny.com/en/joomla-extensions/solve-undefined-ds-constant-joomla-3-error

But then I couldn't update the joomla. I get a popup dialog with message "Invalid login".

I don't know what to do to update the joomla. Can you help me? What I do wrong?

Thanks.

  • In regards to dropping the usertype column from the #__users table, have a look at these answers: joomla.stackexchange.com/questions/4791/… – Lodder Mar 10 '15 at 12:14
  • As for the errors coming from the poweradmin extension, try updating to the latest version of this extension – Lodder Mar 10 '15 at 12:16
  • How do I recognize if an extensions is compatible with joomla 3.x? How I can see this? – user3846 Mar 10 '15 at 13:06
  • Check the Joomla Extensions Directory. I've already check poweradmin and it is J3.x compatible, but simply ensure you have the latest version installed – Lodder Mar 10 '15 at 13:45
2

A couple of things to try:

  1. Disable "System - Remember Me" plugin before running the upgrade step (and re-enable after successful update). It's not clear whether you still need to do this step (see answers to Still required to turn Remember me off when migrating from 2.5 to 3.x?) but it won't do any harm.

  2. The most likely cause is an extension which is not Joomla 3.x compatible. Ensure all third party extensions are updated to the latest versions and are Joomla 3.x compatible before running the update step.

If the update still does not work, I suggest removing as many third party extensions before the update as possible - especially extensions that can be reinstalled easily without losing associated data or where you would need to spend a lot of time reconfiguring settings etc.

1

I just did it a week ago.

disable ALL plugins/modules/extensions/components etc

then upload all joomla 3.4 files via FTP to your website's root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.