Joomla website backup not restoring on my server using kickstart.php. Backup-file details are as follows- backup-file extension : .jpa, backup-file size : 980MB.

enter image description here After clicking on "Start" button to restore backup, next error screen is as below:

  • Hi OjhaRavi! Could you give us more information please. What error messages did you get? What happened when you tried to use kickstart.php?
    – TryHarder
    May 17, 2014 at 5:46
  • Yes, please write some more details. I was frozen scared when I did my first restore (akeeba + kickstart) but then the result was great... May 17, 2014 at 6:34
  • 1
    An error occured unterminated string literal '); if( valid_pos == -1 ) { // Valid data not found in the response msg = 'Invalid AJAX data received:' + msg; if(errorCallback == null) { if(akeeba_error_callback != null) { akeeba_error_callback(msg); } } else { errorCallback(msg); } return; } else if( valid_pos != 0 ) { // Data is prefixed with junk junk = msg.substr(0, valid_pos); message = msg.substr(valid_pos); } else { message = msg; } message = message.substr(3); // Remove triple hash in the beginning // Get of rid of junk after the data var valid_pos = message.lastIndexOf('
    – Ravi Ojha
    May 17, 2014 at 7:45
  • Small error message in 1st line "An error occured" in next line "unterminated string literal". Below the error messages code written is mentioned in above comment.
    – Ravi Ojha
    May 17, 2014 at 8:19

2 Answers 2


Try this:

  1. Download the jpa archive to your local computer
  2. Extract it with https://www.akeebabackup.com/products/akeeba-extract-wizard.html and use the setting to "Ignore the most errors"
  3. Check if a folder called "AwStats" is there and delete this folder (see for explanation the link by sources.)
  4. Upload the extracted files via FTP to you webserver
  5. Test



  • .jpa backup file extracted with Akeeba Extract Wizard on local end. Created .zip of extracted backup files and then uploaded the .zip file on server. On server unzip the .zip file in testdir directory and given permission of 777. Start accessing server url(i.e. www.example.com/testdir) in browser and backup restoration started
    – Ravi Ojha
    May 22, 2014 at 13:54
  • If you need folder and file premissions of 777, then it's time to change the hoster a your server enviroment. It's not recommended, because of security reasons. Maybe your server is not joomla or generaly cms friendly configured and that's maybe the real problem! May 22, 2014 at 14:10

It can be that your backup file is corrupted. I would suggest to try to restore the jpa archive in your local machine using Akeeba extract wizard, to get closer to a conclusion that the file can be restored or it is damaged. If it can not be restored locally, then there is a big chance that your archive is corrupted. Try to re-backup, but before you do so, also check what else directories apart of the joomla core ones are included in your backup, as it possible that you also include long logs files that might cause you issues restoring them, as you will read in the next lines.

Other possible issues why you can't restore it on your server are the time-outs, especially if your archive contains very big files (e.g. logs files as described above). You could try modifying the php.ini file and adjust the max_execution_time to higher value (e.g. > 120).

Another possibility could be that there are some permissions issues (??). What is the operating system of your server ?

  • On my local system the same file restored properly, but having problem on restoring on Server.My Server OS is Ubuntu-64bits.
    – Ravi Ojha
    May 19, 2014 at 4:04
  • Tried with increase in max_execution_time = 600/1800, but it do not work. Permission given is 777. Also tried with 755 to directories and 644 to files.
    – Ravi Ojha
    May 19, 2014 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.