0

I failed my latest attempts to backup my Joomla2.5 website after the following error message from Akeeba:

Backup Failed

The backup operation has been halted because an error was detected.

The last error message was:

AEAbstractDump :: Database Error: Unknown system variable 'OPTION' SQL=SET OPTION SQL_BIG_SELECTS=1

I searched parts of this text on Google but didn't work out much: only this forum discussion in polish makes me guess I should comment the code line

$db->setQuery('SET OPTION SQL_BIG_SELECTS=1');

in the file mysql.php, whose path is given.

Do you agree trying this to solve the problem? Can you explain what caused this error to occur? I would just like to understand a bit more of what happened before handling php files. Thank you.

1

Don't comment just replace 'SET OPTION SQL_BIG_SELECTS=1' with 'SET SQL_BIG_SELECTS=1'. Apparently the syntax changed with mySQL 5.6 or something.

After a little more searching, this error message occurs because your host has updated to MySQL 5.6. The query SET OPTIONS SQL_BIG_SELECTS=1 fails because the new syntax is SET SQL_BIG_SELECTS=1 (without the OPTIONS keyword).

From https://www.akeebabackup.com/support/akeeba-backup-3x/14912-aeabstractdump--database-error.html

  • Hi! Thank you. Lines around 61 of that file say: if(version_compare($dbVersion, '5.6', 'lt')) { // Pre-5.6 MySQL $db->setQuery('SET OPTION SQL_BIG_SELECTS=1'); } else { // MySQL 5.6 or later $db->setQuery('SET SQL_BIG_SELECTS=1'); } It looks like it considers the syntax change already. How should I act next? – MattAllegro Mar 7 '15 at 18:40
  • Comment out the the entire block and just try if "$db->setQuery('SET SQL_BIG_SELECTS=1');" works. – Ville Niemi Mar 7 '15 at 18:49
  • Tried, but it doesn't change: same error message. Actually, commenting both syntax, I could manage to successfully complete the backup. – MattAllegro Mar 7 '15 at 19:11
  • 1
    @MattAllegro If it doesn't give an error and the backup is functional, I guess you don't need it? It should default to 1 anyway, Akeeba added that statement because some servers change the default values so that it gets set 0, which results in incomplete backup and an error (which you did not see, so all should be well?). Which database version are you using? – Ville Niemi Mar 7 '15 at 19:38
  • 1
    @MattAllegro Yes, it was only added because some servers are badly configured. Just verify that the backup works. – Ville Niemi Mar 8 '15 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.