1

Im gonna create an online shop using this template: https://www.gavick.com/joomla-templates/responsive-ecommerce-virtuemart-joomla-template,92 But it says that the template only supports VirtueMart 2.6 and I have to use Joomla 2.5... My question is... can't I install VM 2.6 in Joomla 3.X (?)

  • Some of the newer templates from Gavick supports VirtueMart 3, namely Storefront, Instyle, Shop&Buy and Storebox. – johanpw Mar 5 '15 at 13:54
1

No, you can't.

For starters, the XML file uses the <install> tags which were used in Joomla 1.5 but still compatible in 2.5, so trying to install it will result in:

Warning

JInstaller: :Install: Can't find Joomla XML setup file.

In addition to that, it's probably using older coding standards, which will result in PHP errors

I would simply suggest finding another template that's compatible with VirtueMart 3.x (Joomla 3.x)

0

According to this quite long tread from the GK Forums, the template has been updated with a Joomla 3/VM3-compatible version (just scroll down almost to the bottom):

Yes. Bike store form J3.x and VM3.x was released 2 days ago

That way you can install the J3-compatible template and run your site using the latest Joomla and VM versions (unless you've already found another solution to your problem :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.